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With Parallels Desktop you no longer have to choose between the Mac and the PC. Parallels 
Desktop lets you use Windows side-by-side with macOS on your Mac. 

Use this guide to quickly set up and start using Parallels Desktop for Mac App Store Edition. 

(Throughout this guide, Parallels Desktop App Store Edition will be referred to as Parallels Desktop.) 

 

In This Chapter 
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Set Up Your Mac to Use Windows Programs .......................................................... 8 
Other Operating Systems ....................................................................................... 8 
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Welcome to Parallels Desktop App Store Edition 
 

What You Can Do 
With Parallels Desktop, you can: 

• Install various operating systems and use them together 

• Copy and paste text and drag and drop objects between Mac and Windows 

• Run Windows games and other 3D programs 

• Easily share macOS files, devices, and other resources with Windows 

• And much more 
 

Set Up Your Mac to Use Windows Programs 
After just a few steps, you can begin using Windows programs on your Mac. Setting up your Mac 
to run Windows programs involves the following steps: 

Step 1: Install Parallels Desktop (p. 9). 

Step 2: Install Windows on your Mac (p. 12). 

Step 3: Install your Windows programs (p. 16). 

You only need to follow these steps once. Then you can open and use your Windows programs on 
your Mac anytime you like, just as you do with your Mac applications. 
 

Other Operating Systems 
Important: This guide is focused on using Parallels Desktop with Windows. 

Using Parallels Desktop you can run several other kinds of operating systems (p. 106) on your Mac, 
such as several flavors of Linux and Unix, Windows 10, older versions of Windows, and more. 

Finding Information On Running Other Operating Systems 

You can find much more information and details on using Parallels Desktop to run other operating 
systems on your Mac by checking the resources listed in Get Support (p. 139). 

Additionally, though not explicitly stated, many of the instructions presented in this guide also apply 
to supported operating systems other than Windows. And some important instructions relating to 
other operating systems are in the Advanced Topics (p. 106) section. 

 



 

 

Follow the instructions in this chapter to install Parallels Desktop. 

In This Chapter 

What You Need ...................................................................................................... 9 
Install Parallels Desktop .......................................................................................... 10 
Activate Parallels Desktop ....................................................................................... 10 
Set the Language ................................................................................................... 10 
 
 

What You Need 
To use Parallels Desktop for Mac App Store Edition, you need a Mac with the following 
configuration: 

 Minimum 

To run most applications such as Microsoft 
Office, accounting, trading, SAP, MATLAB, 
and more. 

Best Performance 

For graphics-intensive applications, high loads 
and running multiple virtual machines. 

Processor Intel Core 2 Duo, Core i3, Core i5, Core i7, Core 
i9, Intel Core M or Xeon processor 

Intel Core i5, Core i7, Core i9 or Xeon processor 

Memory 4GB of RAM 16GB of RAM or more 

Storage 500 MB for Parallels Desktop application 
installation 

Additional disk space for the guest operating 
system (at least 16GB is required for Windows 
10) 

SSD drive 

Graphics Intel, AMD Radeon, or NVIDIA AMD Radeon Pro graphics card 

Operating 
System 

• macOS Catalina 10.15 

• macOS Mojave 10.14.6 or newer 

• macOS Catalina 10.15 

DirectX 11 requires at least macOS Mojave 
10.14.6, but works best on macOS 10.15 
Catalina. 

Internet connection is required for product activation, updates, and select features. 

For a list of operating systems that Parallels Desktop supports for use with your Mac, see 
Supported Guest Operating Systems (p. 106). 
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Install Parallels Desktop 
 

Install Parallels Desktop 
You can be up and running with Parallels Desktop in a few easy steps: 

1 On your Mac, open App Store. 

2 Search for Parallels Desktop. 

3 Click Get and follow the onscreen instructions. 
 

Activate Parallels Desktop 
Once Parallels Desktop is installed, you need to activate it. Please do the following: 

1 Sign in to Parallels. You can do this either using a Parallels or your social account. If you don't 
have an account, select I am a new user and follow the onscreen instructions. 

2 Once you're signed in, do one of the following: 

• If you don't have a subscription to Parallels Desktop, you can try it free for 14 days. Then you 
will need to buy a subscription. To purchase it, click Subscribe. 

• If you already have a subscription, click I Have Subscription. In the next screen, do one of the 
following: 

• If you have a subscription key but it is not registered in your Parallels account yet, click 
Enter Subscription Key to enter it. 

• If you already have an available subscription which can be used to activate Parallels 
Desktop, select it and click Activate. Please note that if you choose a subscription which is 
already used on another Mac and activate Parallels Desktop on this Mac, the copy of 
Parallels Desktop on the other Mac will be automatically deactivated. 

• If you have a subscription but it is already used to activate Parallels Desktop on another 
Mac, click Buy to purchase a new subscription. 

 

Set the Language 
The Parallels Desktop interface supports the following languages: 

• English; 

• German; 

• French; 

• Italian; 

• Spanish; 
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• Czech; 

• Polish; 

• Russian; 

• Brazilian Portuguese; 

• Japanese; 

• Korean; 

• Chinese Simplified; 

• Chinese Traditional Taiwan. 

Parallels Desktop uses the same language which is chosen for macOS. If macOS uses some other 
language which is not listed above, the Parallels Desktop interface will use English. 

 



 

 

There are a couple ways to get Windows up and running on your Mac: 

• Install Windows (p. 12) 

• Import Windows from Parallels Desktop for Mac or other virtualization software (p. 13) 

In This Chapter 

Install Windows ....................................................................................................... 12 
Import from Parallels Desktop for Mac or Other Virtualization Application .................. 13 

 
 

Install Windows 
If you have a Windows installation source (a DVD disc, an image file, or a USB storage device) and 
a valid Windows product key, you can install Windows on your Mac and use it with Parallels 
Desktop. 

To install Windows: 

1 Open Parallels Desktop (in the Applications folder) and choose File > New. 

2 Prepare your installation media: 

• If you're using a Windows installation ISO image file, be sure you have downloaded the file. 

• If you have a Windows installation disc, insert it into the DVD drive.  

• If you have a USB storage with Windows, connect the storage to the Mac. 

3 Click Install Windows or another OS from a DVD or image file. 

4 Parallels Desktop scans for and lists installable operating systems. If you see the version of 
Windows you want to install, select it, click Continue and go to step 5. 

If the Windows installation source doesn't show up automatically, click Choose Manually to 
browse for it manually. You can browse from the following sources: 

• Image File: If you have a Windows image file, click Image File and drag the image to the 
Parallels Wizard window. Once Windows is detected, click Continue. 

• DVD: If you have a Windows DVD, insert it into the DVD drive. Once Windows is detected, 
click Continue. If your Mac doesn't have a DVD drive, you can use an Apple SuperDrive, 
another Mac's DVD drive via Remote Disc, or make an image from the disc. 

C H A P T E R  3  
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Install or Import Windows 
 

• USB Drive: If you have a bootable USB installer with Windows, click USB Drive and 
connect the drive to the Mac. You'll be prompted to grant access to the drive. Then, once 
Windows is detected, click Continue. 

Note: Parallels Desktop may fail to detect some operating systems (for example, the latest Linux 
distributions). If this happens but you're sure that the operating system can be installed, click Continue, 
specify the OS type manually (if it's not listed, choose Other), and follow the onscreen instructions. 

5 Be sure to leave Express installation selected. 

Note: If you deselect Express installation, be sure to stay near your computer to follow onscreen 
instructions during the installation. Also, you'll need to install Parallels Tools (p. 133) after the installation 
to allow the most seamless operation between Windows and macOS. 

6 Choose what you're going to primarily use Windows for. Parallels Desktop settings will be tuned 
to best fit your needs. 

7 Choose where you want to store Windows from the Location menu. 

8 If you want to pre-set things like how much memory Windows uses or whether it starts 
automatically when you open Parallels Desktop, select Customize settings before 
installation. You can also adjust these settings after the operating system is installed. 

9 Click Continue. 

The assistant installs Windows. 

Once Windows is installed, you can start it up by clicking the power button in Control Center. 

 

Important: The first time you start Windows, Parallels Tools are installed to allow seamless operation 
between Windows and macOS. Once Parallels Tools are installed, you're prompted to restart Windows. 

If you didn't select Express installation in step 5 above, you must install Parallels Tools manually (p. 
133). 

When you install Windows, Parallels Desktop creates an administrator account with a blank 
password. Once the installation is complete, it is recommended that you change the password. 
 

Import from Parallels Desktop for Mac or Other 
Virtualization Application 
With Parallels Desktop you can use Windows that you set up using Parallels Desktop for Mac, as 
well as VMware Fusion, Microsoft Virtual PC, and VirtualBox: 
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1 Open Parallels Desktop (in the Applications folder) and choose File > Open. 

2 Select the Windows data file you want to import, then click Open and follow the onscreen 
instructions. 

• Parallels Desktop for Mac data files end with .pvm. 

• VMware files end with .vmx. 

• Virtual PC files end with .vmc. 

• VirtualBox files end with .xml or .vbox. 

You can also simply drag a Parallels .pvm file to Control Center to add it to Parallels Desktop. 

3 Start Windows (p. 15). 

4 Choose Actions > Install Parallels Tools and follow the onscreen instructions. 

Feature Changes When Importing From Parallels Desktop for Mac 

1 When you import Windows set up using Parallels Desktop for Mac to Parallels Desktop, not all 
of the same features are available. 

2 In Parallels Desktop: 

• Coherence is unavailable. 

• Windows icons and Windows application icons in the Dock are not available. 

• Bridged networking is unavailable. Instead you'll be prompted to use shared networking. 

1 If you go back to using an instance of Windows with Parallels Desktop for Mac, all features will 
again be fully functional. 

 



 

 

Read this chapter to find out all about using Windows applications on your Mac. Learn how to get 
started using Windows applications, set how Windows applications work with macOS, share 
applications, files, and folders between macOS and Windows, connect devices, print, customize 
your keyboard, and more. 

In This Chapter 

Get Started ............................................................................................................ 15 
Set How Windows Works with macOS ................................................................... 19 
Mouse, Trackpad, and Keyboard ............................................................................ 28 
Connect USB Devices ............................................................................................ 37 
Print from Windows ................................................................................................ 40 
Use the Built-in iSight Camera or Another Webcam ................................................. 43 
Show a Presentation on an External Monitor or Projector ........................................ 43 
Protect Your Data ................................................................................................... 45 
Connect to the Internet or a Network ...................................................................... 46 
Optimize Performance ............................................................................................ 48 
Use Windows on Your iPad, iPhone or Android Device ............................................ 50 
Allow Windows Updates While Your Mac is Sleeping ............................................... 51 
Translate Words in Windows .................................................................................. 52 
 
 

Get Started 
In this section, learn how to start Windows, open a Windows application, install more Windows 
applications, and shut down or suspend Windows. 
 

Start Windows 

To use Windows programs on your Mac, Windows must be running. 

You can start Windows by doing the following: 

1 Open Parallels Desktop. 
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2 In Control Center, move the mouse pointer to the Windows icon. 

 

3 Once the icon turns to the Power button, click it. 

Windows starts and you can begin using Windows programs. 
 

Open a Windows Application 

You can open a Windows application in a Windows virtual machine the same way as on a physical 
computer with Windows installed. Click the Start button and click the application you need. 
 

Open a File in Windows 

To open a file in Windows, just drag and drop it to the Parallels Desktop icon in the Dock. The file 
will be opened in the application configured as default for this type of files. 
 

Install Windows Programs 

You install Windows programs on your Mac just as you would on a Windows PC. The two most 
common ways of installing programs are: 

• Downloading an image file or program from the Internet or a network 

• Using a CD or DVD installation disc 

Install a Program from the Internet or a Network 

• Download the image file or program and follow the instructions from the program's source. 

In most cases, you can either run the installation file and follow the onscreen instructions, or simply 
open the downloaded program. 

For more information about connecting to the Internet and networks, see Connect to the Internet or 
a Network (p. 46). 

Install a Program from a CD or DVD Installation Disc 

1 Start Windows (p. 15). 

2 Insert the installation disc. 

3 In most cases, an AutoPlay dialog opens. Click the option to run a setup or install file, then 
follow the onscreen instructions. 
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For more information about using CD and DVD discs with Parallels Desktop, see CD/DVD-ROM. 
 

Shut Down or Suspend Windows 

When you're finished using Windows programs, you can leave Windows running in the background 
as you work with your Mac applications. Or you may want to stop Windows from running so more 
of your computer's resources are available for your Mac applications. There are a few ways to stop 
Windows. You can: 

• Suspend Windows 

• Pause Windows 

• Shut down Windows 

• Stop Windows 

Suspend Windows 

Suspending Windows conveniently freezes all running Windows programs and settings in their 
current state. 

Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Actions > Suspend. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Suspend. 

The next time you start Windows, you resume your progress from exactly where you left off. 

When Windows is suspended, you can safely quit Parallels Desktop and resume your progress 
later. 

Pause Windows 

You can temporarily pause from using Windows and free your computer's resources, such as RAM 
and processor cycles, to be used by your Mac applications by doing one of the following: 

• Click the Parallels icon  in the menu bar and choose Actions > Pause. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Pause. 

To resume using Windows after pausing it, do one of the following: 

• Click the Parallels icon  in the menu bar and choose Actions > Resume. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Resume. 



18 
 

Use Windows on Your Mac 
 

Shut Down Windows 

Shutting down Windows in Parallels Desktop is just like shutting down Windows on a PC. All 
Windows programs close, giving you the opportunity to save your progress if necessary, and 
Windows stops running. 

To shut down Windows, do one of the following. 

• Click the Parallels icon  in the menu bar and choose Actions > Shut Down. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Shut 
Down. 

Stop Windows 

To stop Windows and all open Windows programs immediately, do one of the following: 

• Click the Parallels icon  in the menu bar and choose Actions > Stop. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Stop. 

Important: When you stop Windows this way, none of your data or progress is saved. 
 

Startup and Shutdown Settings 

Using Startup and Shutdown settings, you can choose how to start and shut down the virtual 
machine. 

To access Startup and Shutdown settings: 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Configure. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose 
Configure. 

2 Click Options and select Startup and Shutdown. 

Set to Start and Shut Down the Virtual Machine Manually 

If you want to always start and shut down the virtual machine manually, select Start up and shut 
down manually. 

Specify More Details How to Start and Shut Down the Virtual Machine 

If you want to specify how the virtual machine starts and shuts down, the view mode and what 
happens on closing the virtual machine window, select Custom and do the following: 
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Set Whether Windows Starts Automatically 

Choose one of the following from the Start Automatically menu: 

• Never: Windows never starts automatically. 

• When window opens: Windows starts automatically when you open it from Control Center. 

• When Parallels Desktop starts: Windows starts automatically when you start Parallels 
Desktop. 

Set the Startup View 

Choose one of the following from the Startup View menu: 

• Same as last time 

• Window 

• Full Screen 

• Picture in Picture 

Set What Happens When You Shut Down Windows 

Choose one of the following from the On VM Shutdown menu: 

• Keep window open: If Windows is set to appear in a separate window, the window stays open 
when you stop or shut down Windows. 

• Close window: If Windows is set to appear in a separate window, the window closes when 
you stop or shut down Windows. 

• Quit Parallels Desktop: Parallels Desktop quits when you stop or shut down Windows. 

Set What Happens When You Close the Parallels Desktop Window 

Choose one of the following from the On Window Close menu: 

• Suspend 

• Shut Down 

• Force to stop 

• Ask me what to do 
 

Set How Windows Works with macOS 
Read this section to learn more about setting how Windows works together with macOS. 
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Set Windows to Appear in a Single Window 

You can set the Windows and programs to appear together in their own window. 

 

To switch to Window mode from Full Screen mode, do one of the following: 

• Press Command-Control-F. 

• Move the pointer to the top of the screen until the macOS menu bar appears and click View > 
Exit Full Screen. 

 

Monitoring Windows in a Scalable Window 

You can set Windows to appear in a window that can be resized to any size so that the content 
scales in size with the window. This is called Picture in Picture mode. This mode can be useful if 
you want to monitor applications and other tasks running in Windows as you work in macOS. 

To switch to Picture in Picture mode: 

• From Window mode, choose View > Enter Picture in Picture. 

For more information on Picture in Picture mode, see the Picture in Picture mode settings topic (p. 
126). 
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Set Windows to Take Up the Whole Screen 

You can set Windows to occupy your entire screen, so it looks just like it would if you were using a 
Windows PC. In Full Screen mode, macOS and all of the Parallels Desktop controls are hidden. 

To switch to Full Screen mode, do the following: 

• From Window mode, choose View > Enter Full Screen or click the Full Screen icon  in the 
top left corner of the virtual machine window. 

 

To exit Full Screen mode, press Command-Control-F. 
 

Adjust Full Screen Settings 

You can customize how Windows appears and behaves when in Full Screen mode. 

To access Full Screen settings: 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Configure > Options. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose 
Configure > Options. 
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2 Click Full Screen. 

 

3 In this Full Screen pane, you can adjust any of the settings listed below. 

Set What Shows on Displays Connected to Your Mac 

If you have a second display connected to your Mac, by default when you switch to Full Screen 
mode, Windows is displayed on the primary display and macOS on the secondary. 
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You can choose which display Windows is shown on by dragging its window to that display and 
then clicking the Full Screen icon . 

To extend Windows across all your displays, select Use all displays in full screen. 

 

If you selected to show your virtual machine on all displays when it switches to Full Screen, you can 
also choose Show and hide spaces on all displays simultaneously. 

With this option selected, when you click the virtual machine on one of your displays, it appears on 
all other displays. And when you switch focus to something else on one of your displays, virtual 
machine spaces hide on all other monitors. 

Optimize Full Screen for Games 

If you use a virtual machine to play video games in Full Screen view mode, select Optimize full 
screen for games. With this option selected, macOS Dock, menu bar and notifications will not be 
displayed when you move the mouse pointer to the top and bottom of the screen. 

Allow Windows to set display gamma 

If you're using Windows to play video games, Windows may need to temporarily change your 
Mac's display gamma setting to properly display different visual effects. To allow Windows to 
change gamma settings, select Allow Windows to set display gamma. 

Scale to fit screen 

Using the Scale to fit screen menu, you can configure how Windows is displayed when working in 
Full Screen: 

• Off. If Parallels Tools (p. 118) are installed, Windows resolution matches that of the Mac. If 
Parallels Tools (p. 118) aren't installed, Windows resolution remains unchanged. If it is lower 
than that of the Mac, Windows is displayed on the black background. If higher, Windows has 
scroll bars. 

• Auto. If Parallels Tools (p. 118) are installed, Windows resolution matches that of the Mac. If 
Parallels Tools (p. 118) aren't installed, Windows resolution remains unchanged. If it is lower 
than that of the Mac, Windows is displayed on the black background. If higher, Windows is 
entirely displayed on the screen without any scroll bars. 
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• Keep ratio: No matter whether Parallels Tools (p. 118) are installed or not, Windows resolution 
remains unchanged. If it is lower than that of the Mac, Windows is displayed on the black 
background. If higher, Windows is entirely displayed on the screen without any scroll bars. 

• Stretch: No matter whether Parallels Tools (p. 118) are installed or not, Windows resolution 
remains unchanged but Windows is stretched to occupy the whole screen. 

 

Share Items Between macOS and Windows 

Please read on to learn what you can share between your Mac and Windows. 
 

Copy and Paste Between macOS and Windows 

Parallels Desktop allows you to copy and paste images and formatted text (italic, bold, underlined, 
and of various colors, fonts, and sizes) between macOS and Windows applications. 

To enable copying and pasting between macOS and Windows: 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Configure. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose 
Configure. 

2 Click Options > More Options. 

3 Select Share Mac clipboard. 

4 To preserve text formatting when copying and pasting text, select Preserve text formatting. 

Note: To enable copying and pasting between macOS and Windows, Parallels Tools (p. 133) must be 
installed. In most cases, Parallels Tools are installed by default. Copying and pasting between macOS 
and Windows is unavailable if you isolate macOS from Windows. 

Copy and Paste Files 

You can easily copy and paste files between Windows and macOS by doing the following: 

1 Select a file (or multiple files) and press Command+C on your keyboard to copy it. 

2 Open a folder or click the desktop in the other operating system and press Command-V to 
paste the file. 

Notes: 

1. To enable copying and pasting files between macOS and Windows, in Sharing settings (p. 25) All 
disks or Home folder must be chosen from the Share Folders menu. 

2. If Home folder only is selected in the Share Folders menu (p. 25), you will be able to copy and paste 
files from the Mac to Windows only from the Mac home folder. 
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Share Files and Folders 

Parallels Desktop allows you to share folders between the macOS and Windows file systems, so 
you can easily open macOS files from Windows applications. 

Note: These instructions apply to sharing folders between macOS and Linux as well. 

Access a macOS Folder or File from a Windows Program 

With folder sharing enabled, you can navigate to any shared macOS folder from within a Windows 
program. When you open a file (for example, by choosing File > Open in many programs), your 
shared macOS folders appear as network shared directories labeled "psf." 

To enable macOS folders for sharing with Windows programs: 

1 Start Windows. (p. 15) 

2 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Configure. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose 
Configure. 

3 Click Options and select Sharing. 

4 Do one of the following: 

• To share just the folders in your Home folder, choose  Home folder from the Shared 
Folders menu. 

• To share all your macOS folders, choose All disks from the Shared Folders menu. 

• To share any folder you want, click Custom Folders and click the add (+) button, then 
choose the folder you want to share. You can add more folders by clicking the add (+) 
button again. 
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Once you share a macOS folder with Windows you can: 

• Disable the folder sharing by deselecting On. 

• Change the folder name that will be displayed in Windows by double-clicking the folder 
name in the Name column and typing another name. 

• Restrict writing to this folder by clicking Read & Write in the Permissions folder and 
choosing Read only. You will not be able to add items to the folder. 

5 Click OK. 

Note: 1. To enable folder sharing, the Isolate Windows from Mac option must be disabled on the 
Security tab of the Configuration dialog. 

2. If you're running Linux, shared folders are mounted to the /media/psf or /mnt/psf directory. 

Set macOS and Windows to Use the Same Folders 

You can set macOS and Windows to use the same folders for things like music, documents, 
pictures, your desktop, and deleted files. So for example, if you save a file to the Documents folder, 
it will be in the Documents folder whether you're using a macOS application or a Windows 
program. 

1 Start Windows. (p. 15) 

2 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Configure. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose 
Configure. 

3 Click Options and select Sharing. 

4 Select Share Mac user folders with Windows. 

Your macOS Desktop, Documents, Pictures, Music, Movies, and Downloads folders 
are merged with the corresponding Windows folders, and the macOS Trash is merged with the 
Windows Recycle Bin. 

5 If you only want to map some of the folders, click Configure and select the folders you want. 
To map the macOS Trash to the Windows Recycle Bin, select Merge Recycle Bin with Trash. 

Show an Item from Windows in the Finder 

If Windows is set to appear in a separate window or in full screen mode (p. 20), you can show an 
item from Windows in the macOS Finder. 

• In Windows, right-click (or Control-click) a file or folder and choose Show in Finder from the 
shortcut menu. 

From the Finder you could, for example, apply a color label to an item, or easily drag it to another 
location in the Finder. 
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Note: You can only perform these actions with files stored in shared folders (p. 25). 
 

Set macOS Files to Open in the Windows Application of Your Choice 

You can set files of a particular type that you open from the macOS Finder to open in the Windows 
program of your choice. For example, you could set files ending in .txt to always open in 
Windows Notepad. 

Set macOS Files of a Particular Type to Open in a Windows Program 

To open a macOS file once with a Windows program: 

1 Right-click (or Control-click) the file in the Finder and choose Open With from the shortcut 
menu. 

2 Select a Windows program.  

If you don't see the program you want, click Other and choose a Windows program from 
/username/Applications (Parallels)/Windows Applications. 

To set files of a particular type to always open in a Windows program: 

1 Right-click (or Control-click) a file and choose Get Info from the shortcut menu. 

2 Click the triangle next to "Open with" to expand the section. 

3 Choose a Windows program from the pop-up menu. 

If you don't see the program you want, choose Other and choose a Windows program from 
/username/Applications (Parallels)/Windows Applications. 

4 Click Change All. 
 

Open the Current Safari Page in Internet Explorer 

Some webpages work best when viewed in Windows Internet Explorer. If you are browsing in 
macOS using Safari, you can quickly open the current page in Internet Explorer by doing the 
following: 

1 First you need to enable the "Open in Internet Explorer" plugin. Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Configure. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose 
Configure. 

2 Click Options and select Web. 

3 Click Enable Plugin. 

4 Once the plugin is enabled, click the Open in IE button  in the Safari toolbar. 

If Windows isn't already open, it starts up and the page opens in Internet Explorer. 
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Use a Disk Image with the Virtual DVD Drive 

While working in Windows, you can select a disk image file to be used with the virtual Windows 
DVD drive, as if it was a DVD inside a real drive. To do so: 

1 In Windows Explorer, open Computer or This PC, right-click the DVD drive icon, and choose 
Select disk image. 

2 Locate the disk image you want to use and click Open. 

Note: This functionality is available only for Windows with Parallels Tools installed (p. 133). 
 

Apply macOS Parental Controls to Windows 

If you have administrator rights in macOS, you can use parental controls to prevent others with 
accounts on your Mac from using certain Windows programs or accessing certain web sites. 

To apply parental control settings: 

1 In macOS, choose Apple menu > System Preferences and click Parental Controls. 

2 Click the lock if it's not unlocked, and then enter an administrator name and password. 

3 Select the account that you want to restrict, click Enable Parental Controls, and set up the 
controls. If you want the user to be able to use some Windows programs, be sure to select 
Parallels Desktop in the list of allowed applications. 

For more information on using parental controls, see Mac Help. 
 

Mouse, Trackpad, and Keyboard 
Parallels Desktop lets you configure your mouse or trackpad and your keyboard to work just the 
way you want them to. 

You can also use trackpad gestures to control Windows programs just as you can with macOS 
applications. 

Read on to learn how to customize how your mouse, trackpad, and keyboard work with Windows 
programs. 
 

Set Your Mouse or Trackpad to Right-Click and Middle-Click 

Many tasks in Windows, such as bringing up shortcut menus, are accomplished by right-clicking. 

By default, Parallels Desktop is set to mimic a right-click when you press Shift+Control and click 
the mouse. You can change which key combination triggers a right-click. 
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You can also set your trackpad to allow right-clicking, and if you have an Apple Mighty Mouse 
(included with Apple desktop computers from 2005-2009) or Magic Mouse (included with current 
Apple desktop computers), you can set the mouse to allow right-clicking. 

Most other mice are pre-configured for right-clicking. 

Set the Trackpad for Right-Clicking. 

1 Choose Apple menu > System Preferences and click Trackpad > Point & Click. 

2 Select Secondary click and choose how you want to imitate a right-click. 

Set an Apple Mighty Mouse for Right-Clicking 

1 Choose Apple menu > System Preferences and click Mouse or Keyboard & Mouse. 

2 Choose Secondary Button from the menu to the right of the mouse. 

Now you can press the right side of the mouse to right-click. 

Set an Apple Magic Mouse for Right-Clicking 

1 Choose Apple menu > System Preferences and click Mouse or Keyboard & Mouse. 

2 Select Secondary click. 

Now you can press the right side of the mouse to right-click. 

Set Which Key Combination Triggers a Right-Click or a Middle-Click 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Preferences. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels 
Desktop > Preferences. 

2 Click Shortcuts. 
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3 Select Mouse Shortcuts in the sidebar. 

 

4 Select Secondary click (for right-click) or Middle click. 

5 Click in the corresponding text field and press the key or combination of keys that you want to 
use with a mouse click to trigger a right-click or middle-click. 

You can use any combination of the Control, Option (Alt), Shift, and Command keys. 
 

Control Programs with Trackpad Gestures 

If you have an Apple portable computer, such as a Macbook, or if you have an Apple Magic 
Trackpad, you can use gestures, such as swiping left or right across the trackpad, to control some 
Windows programs. 

Note: You can control some Windows programs using three-finger swipes only if you're using Parallels 
Desktop with macOS Snow Leopard. In OS X Lion and later, three-finger swipes are used by default to 
move between full-screen apps and spaces. 
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The following table provides commands to control some of the more popular Windows programs. 

Action Keyboard and Mouse 
Combination Touchpad Gesture 

General 

Scroll Up, down, left, or right arrow 
Swipe up, down, left, or 
right with two fingers 

Microsoft Power Point 

Start slide show F5 n/a 

End slide show Esc n/a 

Perform the next animation 
or advance to the next 
slide 

N, Enter, Page Down, Right 
Arrow, Down Arrow, Space (or 
click the mouse) 

Swipe right with three 
fingers 

Perform the previous 
animation or return to the 
previous slide 

P, Page Up, Left Arrow, Up 
Arrow, Backspace Swipe left with three fingers 

Zoom in/zoom out Ctrl+wheel up /Ctrl+wheel down Pinch open/pinch close 

Microsoft Word/Excel 

Zoom in/zoom out Ctrl+wheel up /Ctrl+wheel down Pinch open/pinch close 

Windows Media Player 

Start/pause playback Space n/a 

Skip to the next song Ctrl+F Swipe right with three 
fingers 

Play the previous song Ctrl+B Swipe left with three fingers 

Volume up F8, Up Arrow, wheel up n/a 

Volume down F9, Down Arrow, wheel down n/a 

Media Player Classic (k-lite) 

Start playback/pause Space n/a 

Volume up F8, Up Arrow, wheel up n/a 

Volume down F9, Down Arrow, wheel down n/a 

Winamp 

Start playback/pause X to start, C to pause n/a 

Volume up Up Arrow, wheel up n/a 

Volume down Down Arrow, wheel down n/a 

Microsoft Internet Explorer 

Page back Backspace, Option+Left Arrow 
(Alt+Left Arrow) 

Swipe right with three 
fingers 

Page forward Option+Right Arrow (Alt+Right Swipe left with three fingers 



32 
 

Use Windows on Your Mac 
 

Arrow) 

Zoom in/zoom out Ctrl+wheel up/Ctrl+wheel down Pinch open/pinch close 

Mozilla Firefox 

Page back 
Backspace, Option+Left Arrow 
(Alt+Left Arow) 

Swipe right with three 
fingers 

Page forward Option+Right Arrow (Alt+Right 
Arrow) Swipe left with three fingers 

Zoom in/zoom out 
Ctrl-wheel up/Ctrl-wheel down or 
Ctrl-"+"/Ctrl-"-" Pinch open/pinch close 

Windows Picture and Fax Viewer 

Next image Right Arrow Swipe right with three 
fingers 

Previous image Left Arrow Swipe left with three fingers 

Zoom in/zoom out "+"/"-" Pinch open/pinch close 

Rotate clockwise Ctrl+K Rotate right with two fingers 

Rotate counterclockwise Ctrl+L Rotate left with two fingers 

 
 

Use Keyboard Shortcuts 

Both macOS and Windows provide extensive keyboard shortcuts. For example, in macOS you can 
hold down the Command key and press Q (Command-Q) to quit the current application. 

To enter a keyboard shortcut, simply press a key combination on your keyboard. 

You can also enter keyboard shortcuts by doing one of the following: 

• Click the Parallels icon  in the menu bar, then choose Devices > Keyboard and choose a 
key combination. 

• Choose Devices > Keyboard and choose a key combination. 

These methods are most useful for using keyboard shortcuts that include keys not included on a 
Mac keyboard, such as Alt + PrintScreen. 

Note: To use the F1-F12 keys on a MacBook, press and hold the Fn key and then press an F key. 
 

Customize Keyboard Shortcuts 

By default, Parallels Desktop maps common macOS keyboard shortcut key combinations to the 
equivalent Windows key combinations. That way if you're used to, for example, pressing 
Command-C to copy text in macOS, you don't have to switch to the Windows equivalent, Control-
C. 
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You can also use and customize keyboard shortcuts for switching between Full Screen and 
Window view modes, and for showing and hiding Parallels Desktop. 

Customize Keyboard Shortcuts 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Preferences. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels 
Desktop > Preferences. 

2 Click Shortcuts 

3 Select Windows from the Virtual Machines list in the sidebar. 

Or if you're using another operating system with Parallels Desktop and you want to customize 
keyboard shortcuts for it, select it in the sidebar. 

 

When you're using a Windows application, pressing a key combination in the From column 
above triggers the key combination in the To column. 
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4 Do one of the following: 

• To edit an existing key combination, double-click the key combination or select it and click 

the Edit button . Click modifier keys to select or deselect them. If you wish, change the 
character in the text field. 

 

• To delete a key combination, select it and click the Remove button . 

• To add a new key combination, click the Add button . 

If you're using multiple operating systems with Parallels Desktop, you can create keyboard profiles 
for each OS (p. 115). 

Note: 1. Some key combinations can't be edited or deleted. 

2. There are Mac shortcuts that do not have similar shortcuts in Windows For example, you can use the 
F11 key or Fn+F11 combination to see your macOS desktop with Expose, but in Windows there are no 
keys or key combinations that enable you to perform the same action, because there is no Expose in 
Windows. 

Enable or Disable macOS System Shortcuts 

In macOS the function keys on your keyboard (F1, F2, F3 and so on) control functions like 
activating Dashboard and Mission Control, adjusting screen brightness, and controlling the volume. 
By default, when a Windows application is active the function keys and other Mac system shortcut 
key combinations (such as pressing Cmd + Tab to switch between open applications) continue to 
activate macOS functions. 

To set whether function keys and macOS system shortcut key combinations activate functions in 
macOS or Windows: 

1 Click macOS system shortcuts in the sidebar. 

2 Select one of the following from the Send macOS system shortcuts menu: 

• Always: When Windows or Windows applications are active, function keys and other 
system shortcuts always trigger functions in Windows. 

• Never: Function keys and other system shortcuts always trigger functions in macOS. 
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• Auto: If you're working with Windows, system shortcuts that don't function in Windows (for 
example, Control-Up Arrow button to display Mission Control) trigger functions in macOS. If 
you're using macOS as a guest OS and a guest OS or its application is active, system 
shortcuts that are typical only to macOS trigger functions in the guest version of macOS. 

Customize Keyboard Menu 

In Window mode you can enter key combinations by choosing Devices > Keyboard and then 
choosing a key combination. To customize available key combinations, do the following: 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Preferences. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels 
Desktop > Preferences. 

2 Click Shortcuts > Keyboard Menu. 

3 Do one of the following: 

• To add a new key combination, click the Add button . 

• To remove a key combination from the Keyboard menu, select it and click the Remove 

button . 

• To edit an existing key combination, double-click the key combination or select it and click 

the Edit button . Click modifier keys to select or deselect them. If you wish, change the 
character in the text field. 

•  
 

Create New Keyboard Shortcuts 

You can press certain key combinations, called keyboard shortcuts, to quickly trigger various 
actions in Parallels Desktop. For example, you can press Command-Control-F to switch Windows 
to Full Screen mode. You can use existing keyboard shortcuts (you can see them in the Parallels 
Desktop > Preferences > Shortcuts > Application Shortcuts pane), and you can also create 
your own. 

To create a new keyboard shortcut: 
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1 Make a note of the name for the command you want a shortcut for as it appears in a menu in 
Parallels Desktop. For example, if you want to create a new shortcut for switching to Full 
Screen mode, you can see by opening the View menu in Parallels Desktop that the name of the 
menu item is Enter Full Screen: 

 

2 In macOS, choose Apple Menu > System Preferences. 

3 In System Preferences, click Keyboard and click Shortcuts. 

4 Select App Shortcuts in the sidebar and click the Add button . 

5 If you want a new shortcut to work only for Parallels Desktop, choose Parallels Desktop from 
the Application menu. If you leave All Applications selected, the shortcut will work for any 
application that has the same command name and is currently active. 

6 Enter the menu item name from Step 1. 

Important: You must enter the command name exactly as it appears in the Parallels Desktop menu or 
your new shortcut won't work. 

7 In the Keyboard Shortcut field, press the key combination that you want to trigger the action. 

Note: You must create separate shortcuts for commands that change in the menu depending on the 
state of Parallels Desktop, such as Enter Full Screen and Exit Full Screen. 

 

See and Change Windows Input Language In macOS 

While you're working with Windows or any Windows applications, Parallels Desktop shows the 
input language set in Windows in macOS menu bar. 

 

As soon as you switch to Mac, the input language in macOS menu bar changes back to the 
language that was set before you started working with Windows. 

To make this feature work properly, Parallels Tools (p. 119) must be installed and the same input 
languages must be available in Windows and macOS. To learn how to add input languages, please 
refer to the help resources for these operating systems. 

Change Windows Input Language From macOS Menu Bar 

To change the Windows input language from the macOS menu bar: 
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1 Click Windows or your Windows application to make it active. 

2 Choose the language you need from the Input menu available in the macOS menu bar. 

 

Note: The language you're selecting from the Input menu must be also available in Windows. To learn 
how to add a language to the list of input sources in Windows, please refer to the Windows help 
resources. 

If the Input menu isn't available in macOS menu bar, you can set it to show by doing the following: 

1 In macOS, choose Apple menu > System Preferences and click Keyboard. 

2 Click Input Sources. 

3 Select the language or languages you want to use from the sidebar. 

4 Select Show input menu in menu bar. 
 

Connect USB Devices 
Parallels Desktop allows you to use USB devices with Windows. 

To connect a USB device: 

1 Connect the device to your Mac. 
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2 If Windows is running and the device can't be used with both Windows and macOS at the 
same time, you're prompted to choose which one you want to use it with. To use the device 
with macOS applications, click the Mac icon. To use it with Windows programs, click the 
Windows screen. 

 

Important: To be able to use a USB device with Windows programs, you may need to install Windows 
drivers for the device. Typically you can download drivers from the manufacturer's website. 

You can also set what happens when any new external device is connected and set particular 
external devices to always be used with either macOS or Windows (p. 39). 
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Adjust Devices Settings 

In the Devices pane of Parallels Desktop Preferences, you can: 

• Set what happens when you connect any new USB device to your Mac. 

• Set a particular device to always be used with either macOS or Windows. 

 

To access Devices Settings: 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Preferences. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels 
Desktop > Preferences. 

2 Click Devices. 
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Set What Happens When You Connect a New External Device to Your Mac 

Choose one of the following: 

• Connect it to my Mac. New external devices are automatically available for use with macOS 
applications. 

• Connect it to the active virtual machine. New external devices are automatically available for 
use with Windows programs. If Windows isn't running, the external device is connected to 
macOS. 

• Ask me what to do. Each time you connect an external device, you're prompted to choose 
whether you want to connect the device to Windows or the Mac. 

Set a Particular External Device to Always Be Used With macOS or Windows 

If you know you always want a particular external device to be available to either macOS or 
Windows, you can set it to do so by following the instructions below. The device must already have 
been connected to your Mac at least once. 

1 Click the Add (+) button towards the bottom of the window. 

2 Select the device from the list. 

3 Double-click the word (either Computer or some form of Windows) in the Connect To 
column. The word becomes a pop-up menu. 

4 Do one of the following: 

• To set the device to always be available to macOS applications, choose Computer from the 
menu. 

• To set the device to always be available to Windows programs, choose Windows from the 
menu. 

To remove an existing assignment, so that the device no longer automatically connects to macOS 
or Windows, select the device in the External Device column and click the Remove (-) button. 

Important: To be able to use an external device with Windows programs, you may need to install 
Windows drivers for the device. Typically you can download drivers from the manufacturer's website. 

 

Print from Windows 
By default, Windows is set to use the same printer that you use with macOS. Simply print from a 
Windows application the way you normally would. 

You can also set Windows to use a different printer. There are a few ways to set up printing in 
Windows: 

• Share any of the printers connected to your Mac. 
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• Connect to a network printer. 

• Connect a USB printer directly to Windows. 
 

Share a Printer Connected to Your Mac 

You can use any printer connected to your Mac with Windows programs. 

Note: This functionality is also available for Linux with Parallels Tools installed (p. 121). 

To print a document from a Windows program: 

• Open the document and simply print it the way you normally would (for example, choose File > 
Print). 

In the print window, you can choose any printer that's connected to your Mac. 

Share Printers Connected to Your Mac 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Configure. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose 
Configure. 

2 Click Hardware and select Shared Printers. 

Note: The Shared Printers pane is available for Windows 2000 and newer versions of Windows. 

3 Select Share Mac printers with Windows. 

Set a New Default Printer 

By default, Windows is set to use the same default printer as your Mac. To use a different default 
printer for Windows. 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Configure. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose 
Configure. 

2 Click Hardware and select Shared Printers. 

3 Deselect Synchronize default printer. 

Now you can set a new default printer in Windows the way you normally would. 
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Set Up a Network Printer 

You can install a network printer directly into Windows. 

Before installing a network printer in Windows, make sure that: 

• Your Mac can access the Internet. 

• Windows is configured to work in the Shared networking mode (p. 46) and can access the 
Internet too. 

• The user account in Windows has permission to access the network printer. 

• You know the printer IP address. 

After that, you can log in to Windows and install a network printer. To learn how to set up a 
network printer in your virtual machine operating system, please refer to this OS help resources. 
 

Set Up a USB Printer 

You can connect a USB printer directly to Windows. In this case, the printer isn't available to 
macOS. If you want to use the printer to print both from macOS and from Windows, see Share a 
Mac Printer (p. 41). 

To connect a USB printer directly to Windows: 

1 In Parallels Desktop, start Windows. 

2 When Windows starts, install the printer driver. For detailed information on how to do that, refer 
to the printer manufacturer's documentation. Typically you can find drivers on the 
manufacturer's website. 

3 Do one of the following: 

• If the USB printer is already connected to your Mac: 

• Click the Parallels icon  in the menu bar, choose Devices > Printer > Printer and select 
this printer from the list. 

• If the USB printer is not connected to your Mac, connect it. In the New USB device detected 
window, connect the printer to Windows. 

1 In the next step, Windows may set up the printer automatically. If it doesn't, please refer to your 
Windows version help resources to learn how to set up the newly connected printer in 
Windows. 

 

Create a PDF File 

When working with a text document, web page, or other file, you may wish to create a Portable 
Document Format (PDF) file out of it. A PDF file preserves the format and layout of a document, so 
others can see it as if it were printed on the page. 
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To create a PDF file, select Print to PDF (Mac Desktop) when choosing a printer. A PDF file is 
saved on the Mac desktop. 

Note: This functionality is available for Windows guest operating systems provided that Parallels Tools 
are installed (p. 118) and all Mac printers are shared (p. 41) with Windows. 

 

Use the Built-in iSight Camera or Another 
Webcam 
If your Mac or display has a built-in iSight camera, or if you connect a compatible external webcam, 
by default you can use it with Windows. 

To use a built-in iSight or external camera with Windows: 

• Simply open a Windows program that uses a camera, you should be able to select the iSight or 
external camera for use with the program. 

Disable Camera Sharing 

If you don't want Windows programs to be able to use connected webcams or the built-in iSight 
camera, you can disable camera sharing by doing the following: 

1  Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Configure. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose 
Configure. 

2 Click Hardware and click Sound & Camera. 

3 Deselect Share Mac camera with Windows. 
 

Show a Presentation on an External Monitor or 
Projector 
You can easily connect your Mac to an external monitor or projector and show a presentation from 
a Windows application, with little configuration needed. 

To do so: 

1 Start Windows (p. 15) if it isn't already running. 

2 Connect your Mac to the external monitor or projector as you normally would. A message 
appears asking if you're going to show a presentation. 
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3 If you want to show the exact contents of your computer's display on the external display or 
projector, select Mirror display. 

If you don't select Mirror display, certain applications, such as Microsoft Powerpoint, may 
show a presenter view on your computer while showing only the presentation on the external 
display or projector. 

4 Click Yes. Windows switches to Presentation mode, displayed at full screen on both your 
computer's display and external display or projector. After that, you can start showing your 
presentation. 

Note: To learn how to choose on which display the presentation is shown, please refer to Help of the 
application you're using for presentations. 

Important! While you're working in Presentation mode, changing display settings in Windows may 
cause the presentation to malfunction. 

 



45 
 

Use Windows on Your Mac 
 

Protect Your Data 
You probably have important documents, photos, and more on your Mac. When running Windows 
on your Mac, it's especially important to protect your data from viruses and unauthorized use. Read 
this section to learn how. 
 

Isolate Windows from Mac 

You can isolate Windows from macOS, so that they no longer share folders, profiles, and 
applications, connected external devices are no longer automatically accessible by Windows, 
Windows and Mac no longer synchronize volume, and you can no longer copy or move objects 
between Windows and macOS. Isolating Windows from macOS may provide a higher level of 
security by not allowing compromised items from one OS to come into contact with the other. 

To isolate Windows from macOS 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Configure. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose 
Configure. 

2 Click Security. 

3 Select Isolate Windows from Mac. 
 

Encrypt Windows to Protect It from Unauthorized Use 

If you store any important data using Windows programs, it is highly recommended that you 
encrypt Windows to protect your data from any unauthorized use. 

Encrypt Windows 

To encrypt Windows (it must be shut down): 

1 Select Windows and click Actions > Configure > Security. 

2 On the Security tab, click Turn On, specify a password, and click OK. 

Warning: The specified password is very important. You must record it. Without this password, 
you can't start Windows. 

Change Your Password 

To change the password for an encrypted Windows (it must be shut down): 
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1 Select Windows and click Actions > Configure > Security. 

2 On the Security tab, click Change Password, specify a new password, and click OK. 

Remove Encryption from Windows 

To remove encryption from Windows (it must be shut down): 

1 Select Windows and click Actions > Configure > Security. 

2 On the Security tab, click Turn Off. 
 

Connect to the Internet or a Network 
Parallels Desktop allows you to use two types of networking with Windows: 

• Shared Networking: Windows programs share a network connection with macOS. This is the 
default setting. 

• Host-only networking: Windows can access only your Mac. 

In most cases, you don't need to adjust network settings. If your Mac is set to connect to a 
network or to the Internet, Windows programs have access to the same network and the Internet. 

Read on for detailed information on these types of networking and how to configure them. 
 

Share Network Settings Between macOS and Windows 

By default, Windows is set to share network settings with macOS. Windows programs can access 
other computers on your local network and the Internet by using the IP address of your Mac. 
Windows does not have its own IP address on the network.  

In most cases, you don't need to adjust network settings. If your Mac is set to connect to a 
network or to the Internet, Windows programs have access to the same network and the Internet. 
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You may wish to use Shared Network mode in the following cases: 

• Your Mac accesses the Internet via a modem or another non-Ethernet device. 

• You need to access the Internet from inside Windows but are concerned about security. 

To configure Windows to use Shared Networking: 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Configure. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose 
Configure. 

2 Click Hardware and then click Network. 

3 In the Network pane, make sure the Shared Network option is selected. 

Note: In the MAC address field, you can change the MAC address currently assigned to Windows. 
MAC addresses are automatically generated when you first set up Windows on your Mac. However, you 
can modify the default MAC address by typing another value in the MAC address field or clicking the 
Generate button. When entering a new MAC address, make sure that it is unique within your network. 

For the information about troubleshooting networking problems, refer to the Parallels knowledge 
base available at the Parallels website. 
 

Use Host-Only Network Settings 

Parallels Desktop provides a closed network that is accessible only to macOS and Windows. 
macOS is connected to this network via the Parallels Host-Only Networking adapter automatically 
created on your Mac during the Parallels Desktop installation. The addresses for Windows are 
provided by the Parallels DHCP server. 

 

To configure Windows to use Host-Only Networking: 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Configure. 
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• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose 
Configure. 

2 Click Hardware and then click Network. 

3 In the Network pane, make sure the Host-Only Network option is selected. 

Note: In the MAC address field, you can change the MAC address currently assigned to Windows. 
MAC addresses are automatically generated when you first set up Windows. However, you can modify 
the default MAC address by typing another value in the MAC address field or clicking the Generate 
button. When entering a new MAC address, make sure that it is unique within your network. 

For the information about troubleshooting networking problems, refer to the Parallels knowledge 
base available at the Parallels website. 
 

Optimize Performance 
If Windows isn't working as speedily as you'd like, there are several simple ways you can optimize 
its performance. This section contains many helpful instructions for doing just that. 
 

Set How Much Memory is Allocated to Windows 

Parallels Desktop is set to allocate a certain amount of your Mac's available RAM memory to 
Windows and the rest to macOS. If too much memory is allocated to Windows, macOS may slow 
down, which in turn can cause Windows programs to slow down because they're running on top of 
macOS. If, on the other hand, too much memory is allocated to macOS, then macOS applications 
may run well but Windows programs might slow down. 

To optimize the performance of both Windows and macOS, set the memory allocated to Windows 
to be somewhere within the recommended range. 

To set how much memory is allocated to Windows: 

1 Shut down Windows (p. 17). 

2 Choose Actions > Configure > Hardware > CPU & Memory. 

3 Move the memory slider to somewhere within the recommended range, indicated by the 
graphic under the slider. 

If you use Windows programs that require lots of memory, like 3D or video production 
programs, it's best to set the memory allocation towards the high end of the range (move the 
slider to the right). If not, it's usually best to set it closer to the middle. 

Note: No matter how much memory (RAM) your Mac has, the maximum amount of memory that can 
be assigned to Windows is 8 GB. 

If you change this setting and then you don't like how Windows is performing, then try a different 
setting. 
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Optimize Virtual Machine for Productivity or Games 

When creating a virtual machine, you can optimize it according to your needs. You can choose to 
configure the virtual machine for: 

• Productivity. Choose this profile if you're using the virtual machine for your everyday work with 
text editors, email, web browsers, etc. 

• Games only. Choose this profile if you're using the virtual machine to play PC games on your 
Mac. 

You can change this setting after the virtual machine is created: 

1 Start Parallels Desktop. 

2 In Control Center, right-click the virtual machine (it must be shut down) and choose 
Configure. 

3 On the General tab, click Change. 

4 Select the profile that best fits your need. 
 

Work with Windows in Travel Mode 

If you often travel with your MacBook, you must have come across the situations when you had no 
power adapter at hand to charge the Mac's batteries or experienced some problems when 
connecting to public networks. 

Travel Mode makes Windows use less energy to extend the Mac's battery life and adjusts settings 
to connect to public networks. 

Enter Travel Mode 

To switch Windows to Travel Mode, do the following: 

1 Start your virtual machine (p. 15). 

2 When Windows boots up, do one of the following: 

• Click the Parallels icon  in the menu bar and choose Actions > Enter Travel Mode. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Enter 
Travel Mode. 

Quit Travel Mode 

To quit Travel Mode, do one of the following: 

• Click the Parallels icon  in the menu bar and choose Actions > Quit Travel Mode. 
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• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Quit 
Travel Mode. 

Enter and Quit Travel Mode Automatically 

You can also configure your virtual machine to enter and quit Travel Mode automatically: 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Configure. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose 
Configure. 

2 Click Options and select Travel Mode. 

3 To enter Travel Mode automatically, choose one of the following: 

• Always when on battery power: The virtual machine enters Travel Mode when the Mac 
starts working on battery power. 

• When battery power is: Choose from the menu when you want your virtual machine to 
enter Travel Mode. 

• Never: The virtual machine never enters Travel Mode automatically. 

4 To quit Travel Mode automatically, choose one of the following: 

• When connected to power: The virtual machine quits Travel Mode when you connect your 
Mac to power. 

• Never: The virtual machine never quits Travel Mode automatically. 
 

Use Windows on Your iPad, iPhone or Android 
Device 
Parallels Access is a product created by Parallels that allows you to work with your Mac or 
Windows PC and their applications remotely from your iPad, iPhone or Android device. It also 
allows you to work with a remote computer via a web browser. 

If you have Parallels Desktop installed on your Mac, you can use the Parallels Access app to 
access and control Windows. 

Parallels Access lets you: 

• Use any of your Windows programs on your mobile device 

• Remotely start, stop, and reset Windows 

• Connect over Wi-Fi or 3G 

• Access Windows from anywhere over the Internet 
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Get Started 

Before you can use Parallels Access, you must do the following: 

1 On your iPad, iPhone or Android device, download and install Parallels Access from the App 
Store or Google play. 

2 Be sure you have installed Windows on your Mac (p. 12). 

3 In Parallels Desktop, do one of the following: 

• Click the Parallels icon  in the menu bar and choose Preferences. 

• If Windows is running in Window mode (p. 20), choose Parallels Desktop > Preferences. 

4 Click Access. 

5 Read the onscreen instructions to install the Parallels Access agent on your Mac. 

You only have to do these steps once. 

Access Windows from your iPad, iPhone or Android device 

1 Turn on your Mac. 

Your Mac must be on for Parallels Access to access and use Windows. 

2 Open Parallels Access on your iPad, iPhone or Android device and log in to your account using 
the same email and password you used to register Parallels Desktop. 

3 Tap your Mac in the list of available Macs. 

When you access Windows for the first time, you see tips about gestures you can use to control 
Windows. Tap Close to go to the Windows desktop. 

For more information about using Parallels Access, see Parallels Access User's Guide, available 
online. 
 

Allow Windows Updates While Your Mac is 
Sleeping 
Parallels Desktop supports macOS Power nap, which lets you keep aspects of Windows up-to-
date even while your Mac is sleeping. When Power Nap is enabled, services that usually update 
information after Windows wakes from sleep (for example, new emails in email applications and 
new event updates in Calendar) will update while your Mac is in sleep. 

To use Power Nap, your computer must be compatible. See Apple.com for more information. 

To enable Power Nap: 
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1 On your Mac, choose Apple menu > System Preferences and click Energy Saver. 

2 Depending on whether your Mac is working on batteries or is plugged, make sure Enable 
Power Nap while on battery power or Enable Power Nap while plugged into a power 
adapter is selected. 

Note: To learn more about Power Nap, please refer to the macOS help resources. 
 

Translate Words in Windows 
If you're working with Windows and come across a word you don't know, you can easily look it up 
in macOS Dictionary. Just hover the mouse cursor over the word and either press Control-
Command-D or tap (don't click) the touchpad with three fingers. 

Notes: 

1. Parallels Tools (p. 119) must be installed in Windows. 

2. When you hover the mouse over a word, the mouse cursor should change from arrow  to text 
selection . You cannot look for words depicted on pictures. 

 



 

 

Read this chapter to learn which options are available in the Parallels Desktop Preferences and 
virtual machine settings, how these options work, and how to add new devices, such as hard disk 
or DVD-drive, to the virtual machine configuration. 

To access Parallels Desktop Preferences, right-click the Parallels Desktop icon in the Dock and 
choose Preferences. 

 

To access your virtual machine settings, do one of the following: 

• If the virtual machine is running in Full Screen or Window view mode, move the mouse pointer 
to the top of the screen, click Actions and choose Configure. 

 

• If the virtual machine is running in Coherence view mode, click the Parallels icon  in the top 
right corner of the macOS menu bar and choose Configure. 

 

In This Chapter 

Parallels Desktop Preferences ................................................................................. 54 
Virtual Machine Settings .......................................................................................... 67 
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Parallels Desktop Preferences 
In This Chapter 

General Preferences ............................................................................................... 54 
Shortcuts Preferences ............................................................................................ 55 
Devices Preferences ............................................................................................... 62 
Advanced Preferences ........................................................................................... 64 
Parallels Access ..................................................................................................... 66 
 
 

General Preferences 

Use General Preferences to specify whether the Parallels menu is available in the macOS menu bar 
and change the folder where your virtual machines are stored. 

To open these preferences, choose Parallels Desktop > Preferences, then click General. 

 

 

Option Description 

Parallels menu Choose whether the Parallels menu  is available in the macOS menu bar. This 
menu provides a quick access to the Parallels Desktop menus, Preferences, 
Control Center, help resources, virtual machine actions, and more. 

Virtual machines folder Set where new virtual machines are stored. By default, they are saved to the 
Parallels folder inside the user's home folder. 
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Shortcuts Preferences 

Use Shortcuts Preferences to customize keyboard shortcuts, create keyboard profiles for multiple 
operating systems, enable or disable macOS system shortcuts, and more. 

To open these preferences, choose Parallels Desktop > Preferences, then click Shortcuts. 

 

Application Shortcuts 
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You can perform various actions in Parallels Desktop either by choosing menu items from the 
corresponding menus or by pressing key combinations. For example, you can open an existing 
virtual machine either by clicking File > Open or by pressing Command + O. However, if you 
deselect this key combination, the shortcut will not work. 

To customize which actions can be performed by pressing key combinations, do the following: 

1 Choose Application Shortcuts on the Shortcuts tab. 

2 Enable or disable actions that can be performed by pressing key combinations. 

 

macOS System Shortcuts 
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In macOS the function keys on your keyboard (F1, F2, F3 and so on) control functions like 
activating Dashboard and Mission Control, adjusting screen brightness, and controlling the volume. 
By default, when a Windows application is active the function keys and other Mac system shortcut 
key combinations (such as pressing Cmd + Tab to switch between open applications) continue to 
activate macOS functions. 

To set whether function keys and macOS system shortcut key combinations activate functions in 
macOS or Windows: 

1 Choose macOS System Shortcuts on the Shortcuts tab. 

2 Select one of the following from the Send macOS system shortcuts menu: 

• Auto: If you're working with Windows, system shortcuts that don't function in Windows (for 
example, Control-Up Arrow button to display Mission Control) trigger functions in macOS. If 
you're using macOS as a guest OS and a guest OS or its application is active, system 
shortcuts that are typical only to macOS trigger functions in the guest version of macOS. 

• Always: When Windows or Windows applications are active, function keys and other 
system shortcuts always trigger functions in Windows. 

• Never: Function keys and other system shortcuts always trigger functions in macOS. 

To show and hide Parallels Desktop, use the Fn + F6 key combination. To use any other key 
instead of F6, click the corresponding text field and press the key you want. 
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Mouse Shortcuts 

 

 

 

Many tasks in Windows, such as bringing up shortcut menus, are accomplished by right-clicking. 
By default, Parallels Desktop is set to mimic a right-click when you press Shift+Control and click 
the mouse. You can change which key combination triggers a right-click. Do the following: 

1 Choose Mouse Shortcuts on the Shortcuts tab. 

2 Select Secondary click (for right-click) or Middle click. 

3 Click in the corresponding text field and press the key or combination of keys that you want to 
use with a mouse click to trigger a right-click or middle-click. 

You can use any combination of the Control, Option (Alt), Shift, and Command keys. 
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Keyboard Menu 

 

 

 

While working with a virtual machine, you can enter key combinations by choosing Devices in the 
macOS menu bar > Keyboard and then choosing a key combination. To customize available key 
combinations, do the following: 

1 Choose Keyboard Menu on the Shortcuts tab. 

2 Do one of the following: 

• To add a new key combination, click the Add button . 



60 
 

Parallels Desktop Preferences and Virtual Machine Settings 
 

• To remove a key combination from the Keyboard menu, select it and click the Remove 

button . 

• To edit an existing key combination, double-click the key combination or select it and click 

the Edit button . Click modifier keys to select or deselect them. If you wish, change the 
character in the text field. 
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Virtual Machine Shortcuts 

 

 

 

By default, Parallels Desktop maps common macOS keyboard shortcut key combinations to the 
equivalent Windows key combinations. That way if you're used to, for example, pressing 
Command-C to copy text in macOS, you don't have to switch to the Windows equivalent, Control-
C. 

To customize keyboard shortcuts, do the following: 

1 Select your virtual machine from the VIRTUAL MACHINES list on the Shortcuts tab. When 
you're using a Windows application, pressing a key combination in the From macOS column 
above triggers the key combination in the To Windows column. 

2 Do one of the following: 
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• To edit an existing key combination, double-click the key combination or select it and click 

the Edit button . Click modifier keys to select or deselect them. If you wish, change the 
character in the text field. 

 

Click OK to save the changes. 

• To delete a key combination, select it and click the Remove button . 

• To add a new key combination, click the Add button . 
 

Devices Preferences 

Use Devices Preferences to specify where to connect new external devices and permanently 
assign devices to Mac or a virtual machine. 
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To open these preferences, choose Parallels Desktop > Preferences, then click Devices. 

 

 

Option Description 

When a new external device is detected Choose what to do when a new external device is connected to your Mac: 

• Connect it to my Mac. New external devices are automatically 
connected to your Mac and become available for use with macOS 
applications. If you want to connect such a device to a virtual 
machine, use the Devices > USB menu. 

• Connect it to the active virtual machine. New external devices are 
automatically connected to the virtual machine you're currently 
working with and become available for use with the guest OS 
applications. If no virtual machine is running, the external device is 
connected to macOS. 

• Ask me what to do. Each time you connect an external device, 
you're prompted to choose whether you want to connect the device 
to your virtual machine or Mac. 
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Permanent assignments If you want a particular external device to be always available to either Mac or a 
virtual machine, do the following: 

Click the Add (+) button towards the bottom of the 
window. 
Select the device from the list. 
Double-click the word (either Your Mac or some 
virtual machine) in the Connect To column. The word 
becomes a pop-up menu. 
Do one of the following: 

• To set the device to always be available to the Mac, choose 
Your Mac from the menu. 

• To set the device to always be available to a virtual machine, 
choose the virtual machine from the menu. 

To remove an existing assignment, so that the device no longer automatically 
connects to the Mac or virtual machine, select the device in the Devices column 
and click the Remove (-) button. 

 
 

Advanced Preferences 

Use Advanced Preferences to participate in the customer experience program, reset hidden 
messages, and more. 

To open these preferences, choose Parallels Desktop > Preferences, then click Advanced. 

 

 



65 
 

Parallels Desktop Preferences and Virtual Machine Settings 
 

Option Description 

Feedback If you want to help us make Parallels Desktop better fit your needs, please select 
Participate in the Customer Experience Program. Parallels will collect 
information about your Mac and virtual machines configuration. 

Note: Any types of private information like your name, e-mail, 
address, phone number, and keyboard input will not be 
collected. 

Troubleshooting While functioning, Parallels Desktop automatically creates a log file that can be 
used by the Parallels support team for solving problems and improving the 
product. If you select the Use detailed log messages option, Parallels Desktop 
will start creating a more detailed log file. It can be helpful for the Parallels 
support team, but uses more hard disk space and may lower the system 
performance. You're not recommended to enable this option until you're asked 
to do so by the Parallels support team. 

Reset all dialog warnings Some Parallels Desktop dialogs and windows are provided with the Do not 
show this message again option. If you select this option, the corresponding 
dialog will not appear next time you perform the same operation. Using the 
Reset Warnings button, you can reset all dialogs and windows with this option 
selected so that they would be displayed again each time you initiate the 
corresponding operation. 
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Parallels Access 

Parallels Access allows users to work with their Mac and Windows applications from iOS and 
Android devices or via a web browser. 

 

Parallels Access lets you: 

• Use any of your Mac and Windows applications on your mobile device; 

• Remotely start, stop, and reset Windows or Mac; 

• Connect over Wi-Fi or 3G; 

• Access Windows and Mac from anywhere over the Internet; 

• And more... 

For more information about using Parallels Access, see the Parallels Access User's Guide, available 
online. 

 



 

 

Virtual Machine Settings 
In This Chapter 
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Options .................................................................................................................. 69 
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General Settings 

On the General tab of virtual machine configuration, you can edit the virtual machine name, 
configure the virtual machine to better fit your needs, reduce the virtual machine size, and more… 
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To open these settings, choose Actions > Configure, then click General. 

 

 

Option Description 

Guest OS type Click the menu at the top of the General tab to change the guest OS type and 
version. You may need to do this after upgrading the operating system (for 
example, from Windows 7 to Windows 10). The OS indicated in this menu must 
match the OS that is actually installed in the virtual machine. Otherwise, Parallels 
Tools may start working incorrectly. 

Name In this field, you can edit the virtual machine name. 

Description Use this field to add some description to your virtual machine. The description is 
displayed in Control Center together with the virtual machine name. 

Configure for Use this option to choose a profile that better fits your needs. Click Change and 
select what for you usually use the virtual machine. The virtual machine settings 
will be optimized according to your needs. 
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Total size Click Reclaim to compress the virtual machine hard disk(s) and remove 
unnecessary files to free up disk space. 

Note: The total size you see here may differ from the virtual 
machine size in Finder. It's because Apple counts 1 GB as 1000 
MB while Parallels, like most standards, as 1024 MB  

 
 

Options 

Startup and Shutdown Settings 

In the Startup and Shutdown pane, you can configure how the virtual machine starts or shuts 
down. 
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To open these settings, choose Actions > Configure > Options, then click Startup and 
Shutdown. 

 

 

Option Description 

Start up and shut down manually Select this option if you want to always start and shut down the virtual machine 
manually. 
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Custom If you want to specify not only how the virtual machine starts or shuts down but 
also the view mode and what happens on closing the virtual machine window, 
select Custom and specify the following: 

• Start Automatically. Use this menu to set whether the virtual 
machine starts automatically: 

• Never: The virtual machine never starts automatically. 

• When window opens: The virtual machine starts automatically 
when you open it from Control Center. 

• When Parallels Desktop starts: The virtual machine starts 
automatically when you start Parallels Desktop. 

 

• Startup view. Use this menu to choose in which mode the virtual 
machine starts when you start the virtual machine or guest OS 
application. 

 

• On VM Shutdown. Use this menu to set what happens when you 
shut down your virtual machine: 

• Keep window open: If the virtual machine is set to appear in a 
separate window, the window stays open when you stop or shut 
down the virtual machine. 

• Close window: If the virtual machine is set to appear in a 
separate window, the window closes when you stop or shut 
down the virtual machine. 

• Quit Parallels Desktop: Parallels Desktop quits when you stop 
or shut down the virtual machine. 

 

• On Window Close. Use this menu to set what happens when you 
close the Parallels Desktop window. These settings affect what 
happens only when the virtual machine is set to appear in a separate 
window. 

Pause Windows when possible Select this option to conserve your Mac's resources by setting the virtual 
machine to pause automatically when no Windows applications are open. That 
way, more resources such as RAM and CPU can be used for macOS 
applications. 

 
 

Sharing Settings 

In the Sharing pane, you can view and configure the virtual machine sharing settings. 



72 
 

Parallels Desktop Preferences and Virtual Machine Settings 
 

To open these settings, choose Actions > Configure > Options, then click Sharing. 
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Option Description 

Share folders With folder sharing enabled, you can navigate to any shared macOS folder from 
within a Windows application. When you open a file (for example, by choosing 
File > Open in many applications), your shared macOS folders appear as 
network shared directories labeled "\\Mac". 

To enable macOS folders for sharing with Windows applications, do one of the 
following: 

• To share just the folders in your Home folder, choose Home folder 
from the Share folders menu. 

• To share all your macOS folders, choose All disks from the Share 
folders menu. 

• To share any folder you want, click Custom Folders and click the 
add (+) button, then choose the folder you want to share. You can 
add more folders by clicking the add (+) button again. Once you 
share a macOS folder with Windows you can: 

• Disable the folder sharing by deselecting On. 

• Change the folder name that will be displayed in Windows by 
double-clicking the folder name in the Name column and typing 
another name. 

• Restrict writing to this folder by clicking Read & Write in the 
Permissions folder and choosing Read only. You will not be 
able to add items to the folder. 

Shared profile You can set macOS and Windows to use the same folders for things like music, 
documents, pictures, your desktop, and deleted files. So for example, if you save 
a file to the Documents folder, it will be in the Documents folder whether you're 
using a macOS application or a Windows application. 

To enable this functionality, select Share Mac user folders with Windows. 

Your macOS Desktop, Documents, Pictures, Music, Movies, and 
Downloads folders are merged with the corresponding Windows folders, and 
the macOS Trash is merged with the Windows Recycle Bin. 

If you only want to map some of the folders, click Configure and select the 
folders you want. To map the macOS Trash to the Windows Recycle Bin, select 
Merge Recycle Bin with Trash. 
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Map Mac volumes to Windows When you connect an external storage device, such as a USB drive, to your 
Mac, you can access the contents from macOS applications. 

You can set Parallels Desktop to automatically mount storage devices and 
volumes to Windows. That way, you can access the contents from both macOS 
and Windows. 

The following items can be mounted to Windows: 

• Removable drives: External storage devices, such as USB hard 
disks and USB flash drives. 

• CD/DVD drives: CD and DVD drives or mounted CD/DVD images. 

• Network folders: Folders shared over the network. 

To make these items mount to Windows automatically, select Map Mac 
volumes to Windows. 

When you connect a storage device or volume, it is mounted as a network drive. 
For example, a USB flash drive plugged in to your Mac will be accessible from 
both the /Volumes folder in macOS and My Computer in Windows. 

 
 

Full Screen Settings 

In the Full Screen pane, you can configure this view mode-related settings. 
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To open these settings, choose Actions > Configure > Options, then click Full Screen. 
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Option Description 

Use all displays in full screen If you have a second display connected to your Mac, by default when you switch 
to Full Screen mode, Windows is displayed only on one display. 

 

You can choose which display Windows is shown on by dragging its window to 

that display and then clicking the Full Screen icon . 

To extend Windows across all your displays, select Use all displays in full 
screen. 

 

Show and hide spaces on all displays 
simultaneously 

If you selected to show your virtual machine on all displays when it switches to 
Full Screen, you can also choose Show and hide spaces on all displays 
simultaneously. 

With this option selected, when you click the virtual machine on one of your 
displays, it appears on all other displays. And when you switch focus to 
something else on one of your displays, virtual machine spaces hide on all other 
monitors. 

Optimize full screen for games If you use a virtual machine to play video games in Full Screen view mode, select 
Optimize full screen for games. With this option selected, macOS Dock, menu 
bar and notifications will not be displayed. To release the mouse input, press Ctrl 
+ Alt. 

Use Windows gamma settings If you're using the virtual machine to play video games, the virtual machine may 
need to temporarily change your Mac's display gamma setting to properly 
display different visual effects. To allow the virtual machine to change gamma 
settings, select Use Windows gamma settings. This option works in the Full 
Screen view mode only. 
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Scale to fit screen Use this menu to configure how the virtual machine is displayed when working in 
Full Screen: 

• Off. If Parallels Tools are installed, the virtual machine resolution 
matches that of the Mac. If Parallels Tools aren't installed, the virtual 
machine resolution remains unchanged. If it is lower than that of the 
Mac, the virtual machine is displayed on the black background. If 
higher, the virtual machine has scroll bars. 

• Auto. If Parallels Tools are installed, the virtual machine resolution 
matches that of the Mac. If Parallels Tools aren't installed, the virtual 
machine resolution remains unchanged. If it is lower than that of the 
Mac, the virtual machine is displayed on the black background. If 
higher, the virtual machine is entirely displayed on the screen without 
any scroll bars. 

• Keep ratio: No matter whether Parallels Tools are installed or not, 
the virtual machine resolution remains unchanged. If it is lower than 
that of the Mac, the virtual machine is displayed on the black 
background. If higher, the virtual machine is entirely displayed on the 
screen without any scroll bars. 

• Stretch: No matter whether Parallels Tools are installed or not, the 
virtual machine resolution remains unchanged but the virtual 
machine is stretched to occupy the whole screen. 

 
 

Picture in Picture Settings 

In the Picture in Picture pane, you can configure this view mode-related settings. 
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To open these settings, choose Actions > Configure > Options, then click Picture in Picture. 

 

 

Option Description 

Opacity In the Picture in Picture mode, the virtual machine window becomes transparent 
by default. You can specify the level of visibility in the Opacity field by dragging 
the slider between Transparent and Opaque. 

Keep on top of other windows Clear this option if you do not want the virtual machine window to appear on top 
of all other open windows when the virtual machine is in Picture in Picture mode. 

Show window on all Spaces Clear this option if you don't want the virtual machine window to be displayed on 
all Spaces. 

Activate window by Dock icon only Select this option if you want to make the virtual machine window inactive. When 
selected, you will click "through" the window. If you need to make the window 
active again and capture the mouse or keyboard input, click the virtual machine 
icon in the Dock. 
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Web Settings 

In the Web pane, you can enable the plugin for Safari to open web pages in Internet Explorer. 

To open these settings, choose Actions > Configure > Options, then click Web. 
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Option Description 

Safari plugin Some webpages work best when viewed in Windows Internet Explorer. If you 
are browsing in macOS using Safari, you can quickly open the current page in 
Internet Explorer by doing the following: 

Click Enable Plugin to enable the "Open in Internet 
Explorer" plugin. 
Once the plugin is enabled, click the Open in IE 

button  in the Safari toolbar. 

If Windows isn't already open, it starts up and the page opens in Internet 
Explorer. 

 
 

Travel Mode Settings 

Work with your virtual machine in Travel Mode to extend the battery life of your Mac. This mode is 
useful when you're traveling and often use your Mac on battery. 
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In the Travel Mode pane, you can configure when your virtual machine enters and quits Travel 
Mode. To open these settings, choose Actions > Configure > Options, then click Travel Mode. 

 

 

Option Description 

Enter automatically In this section, select when your virtual machine automatically enters Travel 
Mode. Choose one of the following: 

• Always when on battery power. Select this option if you want to 
switch the virtual machine to Travel Mode always when the Mac is 
unplugged and starts working on battery power. 

• When battery power is. In this menu, select the battery charge 
level at which the virtual machine enters Travel Mode. 

• Never. Select this option if you never want the virtual machine to 
switch to Travel Mode. 
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Quit automatically In this section, select when your virtual machine automatically quits Travel Mode. 
Choose one of the following: 

• When connected to power. Select this option if you want the virtual 
machine to quit Travel Mode when the Mac is connected to power. 

• Never. Select this option if you never want the virtual machine to 
quit Travel Mode automatically. Only manual interaction is allowed. 

 
 

More Options 

In the More Options pane, you can choose whether to share the Mac clipboard and set whether to 
sync time from macOS. 

To open these settings, choose Actions > Configure > Options, then click More Options. 
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Option Description 

Time Select Sync from Mac to synchronize the virtual machine time settings with 
those of your Mac. 

If you want the virtual machine and macOS time settings to always be the same, 
select Sync from either OS. With this option selected, if you manually change 
the time settings in the virtual machine, they are changed accordingly in macOS 
and vice versa. 

If the time zone set in your virtual machine differs from that of your Mac, you can 
maintain this time difference by selecting Do not sync. 

Share Mac clipboard If you want to copy and paste data between the host and guest operating 
systems, select Share Mac clipboard. If the data you copy and paste between 
macOS and your virtual machine is text and you want to preserve text 
formatting, select Preserve text formatting. 

 
 

Hardware Settings 

CPU & Memory Settings 

In the CPU & Memory pane, you can view and configure the CPU- and memory-related settings. 
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To open these settings, choose Actions > Configure > Hardware, then click CPU & Memory. 

 

 

Option Description 

Processors Use this menu to change the number of virtual CPUs allocated to your virtual 
machine. 

Memory Use this menu or slider to change the amount of memory allocated to your virtual 
machine. To optimize the performance of both the virtual machine and macOS, 
set the memory allocated to the virtual machine to be somewhere within the 
recommended range. 

Adaptive Hypervisor Select this option to set Parallels Desktop to automatically optimize performance 
for the virtual machine or macOS depending on which application you're working 
with at the moment. When you're using a virtual machine app, more resources 
are given to the virtual machine, and when you're using a macOS application, 
more resources are given to macOS. 
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Graphics Settings 

In the Graphics pane, you can view and configure the amount of video memory available to the 
virtual machine video card, set resolution, and more. 

To open these settings, choose Actions > Configure > Hardware, then click Graphics. 

 

 

Option Description 

Memory Use this field to set the amount of video memory that will be available to the 
virtual machine. Auto is recommended. 

When Auto is selected, Windows may use system memory as graphics memory. 
If any of your Windows applications reports that it lacks graphics memory, please 
increase the amount of system memory (p. 83) within the recommended range. 
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Resolution If you're working with Windows 7 or later on a Mac with a Retina display, you 
can choose how Windows is displayed on the screen: 

• Best for Retina display. Windows resolution matches that of the 
Retina display and the DPI setting increases. Windows interface 
elements and text are clear, sharp, and at full size. This option is 
supported by Windows 7 and later. 

• Scaled. Windows resolution and DPI setting don't change. Instead, 
Windows is scaled to full size. As a result, Windows interface 
elements and text are not sharp. This option is useful for Windows 
applications that don't support high-DPI settings and appear small 
onscreen. 

• Best for external displays. Use this option if you're working with 
Windows on multiple displays one of which is non-Retina. The option 
is supported by Windows 8 and Windows 10. 

For Windows XP: 

If you're working with Windows XP on a Mac with a Retina display, Windows 
becomes scaled but its resolution doesn't change. As a result, Windows 
interface elements and text are not sharp. 

However, you can enable full (2880x1800) Retina resolution for Windows by 
selecting Enable Retina resolution. At such a high resolution, Windows 
interface elements and text become sharp but small. 

3D acceleration This menu is available for Linux virtual machines only. If you want to use games 
and applications that require video cards that support OpenGL, select On from 
the 3D acceleration menu. 

For Linux guest operating systems, Parallels Desktop supports OpenGL 2. 

 

In Windows virtual machines, this menu is not available because 3D acceleration 
is turned on by default. For Windows, Parallels Desktop supports DirectX 10 or 
DirectX 11.0 - this depends on the version of macOS installed on your Mac. In 
macOS 10.14.4 Mojave and later, Parallels Desktop supports DirectX 11.0. 

•  

If any of your Windows or Linux apps claims that it requires a higher version of 
DirectX or OpenGL, please let us know about this application on the Parallels 
forum. To access the forum, either click Help > Suggest a Feature or use the 
following direct links: 

• for DirectX - https://forum.parallels.com/threads/directx-11-support-
list-of-titles.340556/ 

• for OpenGL - https://forum.parallels.com/threads/opengl-3-support-
list-of-app-titles.340621/ 

Vertical synchronization Sometimes in games and 3D applications, a newly rendered frame may overlap 
a previously rendered one and then screen tearing happens. This occurs when 
the video card or the software using it begins updating the actively-displayed 
memory in a manner that is out of sync with the monitor's refresh rate. To 
prevent screen tearing, select the Vertical synchronization option. 

Automatic graphics switching This option is visible only if your Mac supports graphics switching. Select this 
option for better battery life or clear for better performance. 



87 
 

Parallels Desktop Preferences and Virtual Machine Settings 
 

 
 

Mouse & Keyboard Settings 

In the Mouse & Keyboard pane, you can view and configure the mouse- and keyboard-related 
settings. 

To open these settings, choose Actions > Configure > Hardware, then click Mouse & Keyboard. 
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Option Description 

Mouse If you play games in a virtual machine, the Mouse menu allows you to set how to 
use a mouse: 

• Auto-detect for games. This is a recommended default setting. If 
you're working with a guest OS application, the mouse moves freely 
between the guest operating system and macOS. However, when 
you start a game, the mouse input is automatically captured in the 
virtual machine so that you couldn't move the mouse to macOS by 
mistake and automatically released when you quit the game. 

• Optimize for games. If your mouse accidentally moves to macOS 
when you're playing a game, select this option to make the mouse 
work in the virtual machine only. To release the mouse input and 
switch to macOS, press Ctrl + Alt. 

• Don't optimize for games. In some rare cases, Parallels Desktop 
may detect an application as a game and the mouse starts working 
incorrectly with the application. If you have this problem, choose 
Don't optimize for games. 

Keyboard If you play games in a virtual machine, the Keyboard menu allows you to set 
how to use a keyboard: 

• Auto-detect for games. This is a recommended default setting. 
When you launch a game in a virtual machine, the signals from the 
modifier keys Option (Alt), Ctrl, and Shift are processed immediately. 

• Optimize for games. Select this option if you use the virtual 
machine only to play games. 

• Don't optimize for games. Select this option if you don't play 
games in the virtual machine. 

Note: You're not recommended to optimize keyboard for 
games when not playing games. Some key combinations with 
the Ctrl, Alt, Shift or Option keys may not work. 

Mouse pointer sticks at window edges When working with a virtual machine in Window view mode, you may often need 
to move the mouse pointer to the edges of the virtual machine window to display 
various guest OS items: for example, to display the Start menu in Windows 8, 
hidden taskbar in Windows XP, or macOS menu bar when any of the guest 
macOS applications is running in full screen. 

The Mouse pointer sticks at window edges option makes the mouse pointer 
pause for a while at the edges of the virtual machine window and you won't 
move the mouse outside of the virtual machine window by mistake. To move 
past the edge, just move the mouse quickly. 

Smooth scrolling Select this option for the mouse to scroll smoothly. 

 
 

Shared Printers Settings 

In the Shared Printers pane, you can share the Mac printer with the virtual machine, sync the 
default printer, and more. 
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To open these settings, choose Actions > Configure > Hardware, then click Shared Printers. 

 

 

Option Description 

Share Mac printers with Windows Select this option to share the printer connected to your Mac with the virtual 
machine. 

Synchronize default printer By default, virtual machines are set to use the same default printer as your Mac. 

To use a different default printer for your virtual machine, deselect Synchronize 
default printer. After that, you can set a new default printer in the guest OS the 
way you normally would. 
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Show page setup options before 
printing 

When you choose to print a document from the virtual machine, first you need to 
set how the document will be printed. You usually have to specify various 
printing settings, such as orientation, page size, whether to print the document 
on one or both sides, etc. Once everything is ready and you click Print in the 
virtual machine, the macOS window with printing settings appears as well. It's 
done by default for you just to ensure that the document will be printed exactly 
the way you want. Or you can specify additional settings, for example, select to 
Save as PDF instead of printing. 

To make the documents print without showing this macOS page setup window, 
deselect Show page setup options before printing. 

 
 

Network Settings 

In the Network pane, you can view and configure the virtual machine network adapter-related 
settings. 
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To open these settings, choose Actions > Configure > Hardware, then click Network. 

 

 

Option Description 

Source Use this menu to choose one of the following network types for the virtual 
machine network adapter: 

• Shared Network. Select this option to enable the Network Address 
Translation (NAT) feature for the virtual machine. In this case, your 
virtual machine will share whatever network connection is currently 
used by your Mac. 

• Host-Only Network. Select this option to allow the virtual machine 
to connect to your Mac and the virtual machines residing on it and to 
make it invisible outside the Mac. If this option is selected, the virtual 
machine cannot connect to the Internet. 
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MAC In the MAC field, you can change the MAC address currently assigned to the 
virtual machine. MAC addresses are automatically generated during the virtual 
machine creation. However, you can modify the default MAC address by typing 
another value in the MAC field or clicking the Generate button. When entering a 
new MAC address, make sure that it is unique within your network. This option is 
for advanced users only. 

Type In this menu, you can change the type of the network interface card. You're not 
recommended to change the default setting unless you're told to do so by the 
Parallels support team. This option is for advanced users only. 

 
 

Sound & Camera Settings 

In the Sound & Camera pane, you can view and configure the sound device parameters and share 
the Mac's camera with the virtual machine. 

To open these settings, choose Actions > Configure > Hardware, then click Sound & Camera. 
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Option Description 

Sound Output Use the Sound Output list to choose the necessary device: 

• Default. Select this option if you want to use the output device set 
as default in macOS. 

• Built-in Output. Select this option if you want to use one of the 
output devices from your Mac. 

• Mute. Select this option if you want to mute the output device. 

Microphone Use the Microphone list to choose the necessary device: 

• Default. Select this option if you want to use the microphone set as 
default in macOS. 

• Built-in Microphone. Select this option if you want to use the built-
in microphone. 

• Mute. Select this option if you want to mute the microphone. 

Sync volume with Mac For Windows XP and later with Parallels Tools installed, you can set Windows 
and macOS volume levels to always be the same. With the Sync volume with 
Mac option selected, if you manually change the volume level in Windows, it is 
changed accordingly in macOS and vice versa. 

 

If Parallels Tools are not installed, this option is called Use Mac sound volume. 
When it is selected, Windows has the same sound volume as in macOS. 

Share Mac camera with Windows Use this option to enable or disable camera sharing. 

Type From the Type menu, you can select the type of sound card you want to use in 
the virtual machine. You can choose between AC'97 and HD Audio. 

 
 

USB Settings 

In the USB pane, you can view and configure the USB-related settings. 
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To open these settings, choose Actions > Configure > Hardware, then click USB. 

 

 

Option Description 

Enable USB 3.0 Use this option to enable or disable USB 3.0 support. 

 
 

Hard Disk Settings 

In the Hard Disk pane, you can view and configure the virtual machine hard disk-related settings. 
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To open these settings, choose Actions > Configure > Hardware, then click Hard Disk. 

 

 

Option Description 

Source Use this field to specify the virtual hard disk file (.hdd) that emulates the virtual 
machine hard disk: 

• To use a virtual hard disk file as the virtual machine hard disk, 
choose the virtual hard disk file from the list, or click Choose an 
image file and specify the path to the desired image file (.hdd). 
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Properties Click this button to edit the hard disk properties: 

• Size. Use this field or slider to change the disk size. 

• Expanding disk. Deselect this option to convert the disk format 
from expanding to plain. 

• Split the disk image into 2 GB files. Select this option if you want 
the virtual hard disk to be split. 

Location Use this field to specify the type of interface for connecting the hard disk. This 
option is for advanced users only. 

 
 

CD/DVD Settings 

In the CD/DVD pane, you can view and configure the virtual machine CD/DVD-ROM settings. 

To open these settings, choose Actions > Configure > Hardware, then click CD/DVD. 
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Option Description 

Source Use this field to specify the source device or image file that emulates the virtual 
machine CD/DVD drive: 

• To use a physical CD/DVD drive as the virtual machine CD/DVD 
drive, select the physical device name from the list. 

• To use an image file as the virtual machine CD/DVD drive, choose 
the image file from the list, or click Choose an image file and 
specify the path to the desired image file. 

Location Use this field to specify the type of interface for connecting the device. This 
option is for advanced users only. 

 
 

Boot Order Settings 

In the Boot Order pane, you can view and configure the virtual machine boot sequence, that is, the 
order in which the virtual machine will try to load the operating system from different boot devices. 
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To open these settings, choose Actions > Configure > Hardware, then click Boot Order. 
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Option Description 

Boot order Use this list to edit the boot order settings. The currently supported boot devices 
are listed below: 

• Hard Disk. Select this device if you want the virtual machine to boot 
up from its virtual hard disk drive. 

• CD/DVD. Select this device if you want the virtual machine to boot 
up from the media connected to its virtual CD/DVD drive. 

Note: The virtual machine will use the CD/DVD drive specified 
as CD/DVD-ROM in its configuration. 

• External device. Select this device if you want the virtual machine 
to boot up from a bootable external device (USB, FireWire, 
Thunderbolt, etc.) connected to your Mac. Once selected, choose 
the device from the External boot device menu located below. 

• Floppy Disk. Select this device if you want the virtual machine to 
boot up from a floppy disk image connected to its virtual floppy disk 
drive. 

• Network. Select this device if you want your virtual machine to boot 
from a network adapter using PXE (Pre-Execution Environment). 

Note: The virtual machine will use the network adapter 
specified as Network in its configuration. 

Every time you start the virtual machine, it tries to boot from the device specified 
as the first one in the Boot order list. If the virtual machine cannot boot from the 
first device (for example, no media is connected to it), the virtual machine 
proceeds to the second device in the list and tries to boot from this device, and 
so on. 

In this list, you can perform the following operations: 

• Change the currently set boot sequence by selecting the name of 
the corresponding boot device and moving it up or down using the 
arrows to the right of the list. 

• Remove a boot device from the sequence by clearing the check box 
next to its name. 

External boot device If you chose External device from the Boot order menu, use this menu to 
select the external boot device. 
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Select boot device on startup If you choose this option, you will see the following message at the virtual 
machine startup: "Press ESC to select boot device". If you press ESC 
pending 5 seconds, you will be able to select a boot device. If you do not press 
ESC, the virtual machine will try to boot from the devices specified in the Boot 
order list. 

Note: Make sure that the device you wish to use for your virtual 
machine booting (hard disk drive, CD-ROM drive, floppy disk 
drive, or network adapter) is available to the virtual machine and 
configured properly. If you do not have any boot devices 
configured in your virtual machine, you will see the following 
error message after you start the virtual machine: “No boot 
device is available”. In this case, you should stop the 
virtual machine and configure at least one boot device for it. 

Boot flags The Boot flags field is intended for specifying the flags that can change the 
virtual machine system behavior. The system flags can be used by the Parallels 
customer support team in cases when something goes wrong in your virtual 
machine. It is not recommended to type anything into this field without being 
instructed to do so by the customer support staff. 

 
 

Printer Settings 

In the Printer pane, you can view and configure the virtual machine printer port settings. 
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To open these settings, choose Actions > Configure > Hardware, then click Printer. 

 

 

Option Description 

Source In the Source field, specify the source device that emulates this printer port: 

• Printers. You can use any of the printers connected to your Mac in 
your virtual machine. Select the appropriate printer from the list. 

• Output File. You can emulate the virtual machine printer port by 
using an output file. Choose an output file from the list or click 
Choose an output file and specify the path to the desired output 
file. 

Port In the Port field, choose the port type. If available, you're recommended to use 
the USB port type. Connecting a printer to a virtual machine via USB ensures 
faster data transfer rate than connecting it via LPT. 
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Floppy Disk Settings 

In the Floppy Disk pane, you can view and configure the virtual machine floppy disk drive settings. 

To open these settings, choose Actions > Configure > Hardware, then click Floppy Disk. 

 

 



103 
 

Parallels Desktop Preferences and Virtual Machine Settings 
 

Option Description 

Source In the Source field, specify the source device or image file that will emulate the 
virtual machine floppy disk drive: 

• If you want to use a physical floppy disk drive, click the Source field 
and select the physical device name from the list. 

• If you want to use a floppy disk image, click the Source field, click 
Choose an image file, and specify the path to the desired floppy 
disk image file. 

 
 

Serial Port Settings 

In the Serial Port pane, you can view and configure the virtual machine serial port settings. 

To open these settings, choose Actions > Configure > Hardware, then click Serial Port. 
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Option Description 

Source In the Source field, select the source device that emulates this serial port: 

• Physical Serial Port. To connect the virtual machine serial port to 
one of the existing serial ports on your Mac, choose the appropriate 
port. 

• Socket. To connect two virtual machines through the sockets, 
choose the appropriate socket. If there are no sockets available, 
click New socket and specify its name in the Enter a socket name 
field. You should also configure the role the virtual machine will play 
in the connection by selecting the necessary role in the Mode list. 
Selecting Server enables you to use this virtual machine to direct the 
other one. Selecting Client enables you to direct this virtual machine 
from the other one. 

• Output File. To connect the virtual machine serial port to an output 
file, choose the appropriate output file or click Choose an output 
file to locate the necessary file. 

 
 

Security Settings 

On the Security tab of virtual machine configuration, you can encrypt your virtual machine with a 
password or isolate the virtual machine from Mac. 

To open these settings, choose Actions > Configure, then click Security. 
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Option Description 

Encrypt with password Use this setting to specify, change or turn off the password your virtual machine 
is encrypted with. 

Isolate Windows from Mac Select this option to isolate the virtual machine from macOS, so that they no 
longer share folders and profiles, connected external devices are no longer 
automatically accessible by the guest OS, the virtual machine and Mac no longer 
synchronize volume, and you can no longer copy or move objects between the 
virtual machine and macOS. Isolating your virtual machine from macOS may 
provide a higher level of security by not allowing compromised items from one 
OS to come into contact with the other. 

 
 

Backup Settings 

On the Backup tab of virtual machine configuration, you can automate saving the virtual machine 
snapshots. 

To open these settings, choose Actions > Configure, then click Backup. 

 

 

Option Description 

SmartGuard If you want to create virtual machine snapshots automatically, select 
SmartGuard > Details and specify how often snapshots are made, how many 
snapshots are stored, and whether you want to be notified before a new 
snapshot is created. 
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Work with Virtual Machines 
Read this section for basic information about working with virtual machines. 
 

Supported Guest Operating Systems 

You can install the following guest operating systems into Parallels Desktop virtual machines: 

 Parallels 
Tools 

Windows 

Windows 10       

Windows 8.1       

Windows 8       

Windows Server 2019       

Windows Server 2016       

Windows Server 2012 R2       

Windows 7 (SP0-SP1)       

Windows Server 2008 R2 (SP0-SP2)       

C H A P T E R  8  

Advanced Topics 
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Windows Vista Home, Business, Ultimate and Enterprise (SP0-SP2)       

Windows Server 2003 R2 (SP0-SP2)       

Windows XP (SP0-SP3)       

Windows 2000 Server, Professional SP4       

Linux 

Red Hat Enterprise Linux (RHEL) 7, 6       

CentOS Linux 7, 6       

Fedora Linux 30*, 29       

Ubuntu 19.04, 18.04 LTS, 16.04 LTS       

Debian GNU/Linux 9, 8       

SUSE Linux Enterprise 15       

OpenSUSE Linux 15.1, 15       

Kali 2019, 2018       

Linux Mint 19, 18       

Elementary 5       

Manjago 18       

Mageia 7, 6       

Gentoo Linux  

Solaris 11, 10  

openBSD 6  

FreeBSD 12, 11  

openVZ 7       

eComStation 2, 1.2  

ReactOS 0.4  

Android OS*       

macOS 

macOS 10.15 Catalina       

macOS 10.14.x Mojave       

macOS 10.13.x High Sierra       

macOS 10.12.x Sierra       

OS X 10.11.x El Capitan       
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OS X 10.10.x Yosemite       

OS X 10.9.x Mavericks       

OS X 10.8.x Mountain Lion       

OS X 10.7.x Lion       

OS X 10.7.x Lion Server       

OS X 10.6.x Snow Leopard Server       

* - only the version downloaded using the Parallels Desktop Installation Assistant. 

Parallels Tools for Linux require X Window System version 1.15 - 1.20 and Linux Kernel version 
2.6.29 - 5.1. 

Please note that Parallels Desktop does not include operating system installation discs or their 
images. You should purchase them separately. 
 

About Virtual Machines 

To add Windows or another operating system to your Mac, Parallels Desktop creates a "virtual 
machine," or a virtual copy of a computer, inside your Mac. You can then install Windows in the 
virtual machine, just as you would install an operating system on a regular computer. 

Many use Parallels Desktop to create one virtual machine and install Windows in it. But you can 
install as many virtual machines as you like, and install a different operating system in each of them. 
That way you can use multiple operating systems together at the same time on your Mac. And just 
like with a regular computer, you can turn virtual machines on and off, configure them, and install 
and use programs. 
 

Set Where New Virtual Machines Are Stored 

By default, Parallels Desktop stores virtual machines in ~/Documents/Parallels. 

To change the default location for new virtual machine installations: 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Preferences. Then click General. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels 
Desktop > Preferences, and then click General. 

2 Choose a location from the Virtual Machines Folder menu. 

All newly created virtual machines are stored in the new location. Any existing virtual machines 
remain in their original locations. 
 



109 
 

Advanced Topics 
 

Arrange Virtual Machines 

If you have many virtual machines, the Control Center window may get overloaded and 
inconvenient to work with. 

You can configure Control Center to show the minimum information - only virtual machine names 
and icons. To do so, click the Parallels Desktop icon in the Dock and choose View > Compact 
View in the macOS menu bar. 
 

Change the Virtual Machine Name 

The name of a virtual machine is displayed in Control Center and at the top of the guest OS 
window when you are running in Window mode. 

To change the virtual machine name: 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Configure. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose 
Configure. 

2 Click General and type a new name in the Name field. 

The length of the name is limited to 50 characters. 
 

Clone a Virtual Machine 

Clone a Virtual Machine 

If you need an exact copy of a virtual machine, you can clone it. A clone is a separate virtual 
machine fully identical to the original one. To make a clone: 

1 Start Parallels Desktop. 

2 In Control Center, select the virtual machine you want to clone (it must be shut down) and 
choose File > Clone. 

3 Choose where you want to store the clone. 

By default, Parallels Desktop stores clones in your Documents > Parallels folder. 

4 Click Save to start cloning the virtual machine. 
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Back Up a Virtual Machine 

Most people don't seriously consider regular backups as a necessity until they have experienced a 
significant data loss. You should create your own backup strategy to protect yourself from data 
loss. Virtual machines are as vulnerable to crashes as physical computers. 

You can back up your virtual machine using one or several of the following methods: 

• Configure the regular backup settings on the Backup tab of the Virtual Machine 
Configuration dialog. 

• Clone the virtual machine with the help of Clone Virtual Machine Assistant. Give a descriptive 
name to the clone and save it in a location specially designated for backups. 

• Copy the virtual machine files manually. 

Configure Regular Backups 

On the Backup tab of the Virtual Machine Configuration dialog, you can choose how to back up 
your virtual machine regularly. You can configure how the virtual machine snapshots will be 
created. 

Clone the Virtual Machine 

You can create a complete clone of the virtual machine using Clone Virtual Machine Assistant. For 
details, see Clone a Virtual Machine (p. 109). 

Copying the Virtual Machine Files 

You can locate your virtual machine in Finder and create a backup copy of the virtual machine file 
(PVM). 

1 In Control Center (or in the virtual machine window if it is shut down), right-click the virtual 
machine name and select Show in Finder from the context menu. In Finder, go to the folder 
where your virtual machine is stored. 

2 Locate the required virtual machine PVM file. 

Note: PVM file is a bundle that contains the virtual machine configuration file (PVS), virtual hard disk file 
(HDD), and other files. For more information about the virtual machine files, see About Virtual Machines 
(p. 108). 

3 Copy the virtual machine's PVM file to a safe location. 
 

Save Snapshots of a Virtual Machine 

A snapshot is a saved state of the guest OS. It's useful to create snapshots, for example, before: 

• you're going to run some programs that may damage the guest OS; or 
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• if you're going to configure some guest OS software that requires a lot of settings; or 

• if you want to mark milestones in the development process. 

Notes: 1. If your virtual machine has one or more snapshots, you can neither compress nor resize the 
virtual hard disk. 

2. Creating a snapshot increases the size of the virtual machine .pvm bundle. 

If something goes wrong, you can revert the changes back to any of your snapshots and continue 
working with the guest OS. 

Create a Snapshot 

1 Start Parallels Desktop. 

2 In Control Center, select the virtual machine for which you want to create a snapshot. 

3 Click Actions > Manage Snapshots. 

4 Click New, specify the snapshot name and click OK. 

Automate the Creation of Snapshots 

The SmartGuard functionality allows you to automate snapshots creation. 

To access settings for automating snapshots: 

1 Start Parallels Desktop. 

2 In Control Center, right-click the virtual machine for which you want to create a snapshot and 
choose Configure. 

3 Click Backup. 
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To automate snapshots, enable SmartGuard, click Details, and do one of the following: 

• Manually set the snapshots frequency and maximum number of snapshots to keep. If you want 
to know when it is time to make the next snapshot and to be able to reject the snapshot 
creation, select Notify me before snapshot creation. 

To set how often snapshots are made: 

• Use the Take a Snapshot Every field. You can set from one to 48 hours. 

If the time interval is less than 24 hours, SmartGuard will allow you to restore the latest hourly, daily 
and weekly snapshot. If the time interval is more than 24 hours, you will be able to restore the latest 
daily, weekly and monthly snapshot. 

To limit how many snapshots are stored: 

• Use the Snapshots to Keep field to set the maximum number of snapshots that can be stored 
on your Mac. 

The maximum available value is 100 snapshots. As soon as Snapshots Manager reaches the limit 
for snapshots and needs to make a new one over limit, it deletes the oldest snapshot. 

Revert to a Snapshot 

To revert to a snapshot: 

1 Start Parallels Desktop. 

2 In Control Center, select the virtual machine that you want to revert. 

3 Click Actions > Manage Snapshots. 

4 Select the snapshot to which you want to revert and click Go To. 

Delete a Snapshot 

To delete a snapshot: 

1 Start Parallels Desktop. 

2 In Control Center, select the virtual machine which snapshot you want to delete. 

3 Click Actions > Manage Snapshots. 

4 Select the snapshot you want to delete and click Delete. 

When you delete an intermediate snapshot, the information it contains is merged into the next 
snapshot. 
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Use Mouse Wheel Horizontal Scrolling 

You can use the mouse wheel horizontal scrolling when working with windows of virtual machine 
applications. This feature is available only if Parallels Tools (p. 133) are installed in the virtual 
machine. 
 

Remove a Virtual Machine 

Remove a Virtual Machine from your Mac 

If you don't need a virtual machine any more, you can permanently remove it from your Mac: 

Warning: Before removing, check that none of the virtual machine files (e.g. virtual hard disk) are 
used by other virtual machines. 

1 Shut down the virtual machine if it is running, right-click in the virtual machine window and 
choose Remove. You can also click File > Remove or right-click this virtual machine in 
Control Center and choose Remove. 

2 Click Move to Trash. 

Remove a Virtual Machine from Control Center 

To temporarily remove a virtual machine from Control Center: 

1 Shut down the virtual machine if it is running, right-click in the virtual machine window and 
choose Remove. You can also click File > Remove or right-click this virtual machine in 
Control Center and choose Remove. 

2 Click Keep Files. 

When you need this virtual machine again, you can easily import it in Parallels Desktop (p. 13). 
 

Download Pre-configured Virtual Appliances 

If you don't have enough time to create a new virtual machine with the required configuration, you 
can download a ready-to-use virtual machine with a predefined configuration. 

Downloading Parallels Virtual Appliances 

Parallels Virtual Appliances are pre-built virtual machines. 

To download such an appliance and use it with Parallels Desktop: 

1 Right-click the Parallels Desktop icon in the Dock and choose New. 

2 Select any of the following free systems and click Continue: 
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• Fedora Linux; 

• CentOS Linux; 

• Debian GNU/Linux. 

3 In the next step, click Download. Once the download starts, you can pause it anytime by 
clicking Pause. To resume the download, click Resume. 

Once the download is complete, you can start working with the virtual appliance in Parallels 
Desktop. 
 

Set the Guest OS Type and Version 

You can change which guest OS a virtual machine is configured to work with. You need to change 
it in the following cases: 

• If you upgrade the guest operating system (for example, from Windows 8 to Windows 10), you 
need to change the guest OS type and version correspondingly or Parallels Tools (p. 118) may 
start working incorrectly. 

• If you create a virtual machine without installing an operating system, and then decide to use it 
with a different operating system than the one you initially specified. 

To set the guest OS type and version: 

1 Shut down the virtual machine. (p. 17) 

2 Open the Actions menu and choose Configure. 

3 Click General and select an OS from the menu just above the Name field. 
 

Set How Many Processors are Allocated to a Virtual Machine 

You can change the number of virtual CPUs that will be used to handle the processes running in a 
virtual machine. Parallels Desktop automatically calculates the maximum allowable number of virtual 
CPU. The calculation is based on the number of physical CPUs available to your macOS computer. 

Note: It is reasonable to use more than one CPU in your guest OS if you are going to use applications 
that perform better under multi-core processors. 

To set how many processors are allocated to a virtual machine: 

1 Shut down the virtual machine. (p. 17) 

2 Open the Actions menu and choose Configure. 

3 Click Hardware > CPU & Memory and select a number from the Processors menu. 
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Check Your Virtual Machine CPU and Memory Usage 

While working with a virtual machine, you may need to check how much memory and CPU time of 
your Mac it is currently using. If the virtual machine is consuming too much and your running Mac 
applications become slow, you can easily reduce the number of CPUs (p. 114) and amount of 
memory (p. 48) assigned to the virtual machine. 

To check the current CPU and memory usage, choose Window > Show Resource Monitor: 

 

Note: you may notice that an amount of memory consumed by a virtual machine is higher than the 
amount of memory allocated to this virtual machine on the CPU & Memory tab (p. 83). It's normal, the 
resource monitor shows memory consumption of all virtual machine processes. 

 

Quickly Free Up Disk Space 

Using Free Disk Space Wizard, you can compress the virtual machine hard disk(s) and remove 
various unnecessary files to free up disk space. 

To quickly compress the disk(s), remove unnecessary files, and free up disk space: 

1 Shut down the virtual machine. 

2 Choose File > Free Up Disk Space. 

Free Disk Space Wizard shows whether you can reclaim any disk space by removing the 
virtual machine snapshots, cache files and various unnecessary files such as statistical, memory 
dump, and crash dump files, which are generated during the virtual machine life cycle. 

You can also conserve disk space by compressing virtual disks manually. 
 

Use Other Operating Systems on Your Mac 
Read this section for the information that's specific to certain operating systems other than 
Windows XP or later. 
 

Customize the Keyboard for the Guest OS 

By default, Parallels Desktop contains four profiles that represent sets of key combinations typical 
for the following OSs: 

• Windows 

• Linux 
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• macOS 

• Generic (for other guest OSs) 

When you create or register a virtual machine, one of these profiles, depending on the guest 
operating system, is assigned to the machine by default. You can create your own profile and 
assign it to your virtual machines. 

To create a custom keyboard profile or edit the existing profiles: 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Preferences. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels 
Desktop > Preferences. 

2 Click Shortcuts. 
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3 Select a virtual machine from the sidebar, click the Profile menu, and select Edit profiles list. 

 

4 Do one of the following: 

• To add a new profile, click the Add button . Specify the new profile name and select the 
base profile from the list. After the profile is created, you can submit the changes by clicking 
OK. Then select this new profile in the Profile list and configure its shortcuts. 

• To remove one of the existing custom profiles, select it and click the Remove button . 

• To duplicate or rename one of the existing profiles, select this profile, click the button , 
and select the corresponding action from the menu. 

Note: You can rename or remove your custom profiles only. 

In the Shortcuts pane of Parallels Desktop Preferences, you can also assign profiles to your virtual 
machines. 

To change a profile assigned to a virtual machine: 

• Select a virtual machine and choose a profile from the Profile menu. 

Emulate a Mouse Right-Click or Middle-Click 

To emulate a mouse right-click or middle-click: 

1 Select Mouse Shortcuts in the sidebar. 

2 Select Secondary click (for right-click) or Middle click. 

3 Click in the corresponding text field and press the key or combination of keys that you want to 
use with a mouse click to trigger a right-click or middle-click. 
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You can use any combination of the Control, Option (Alt), Shift, and Command keys to specify the 
key combination that will be used to emulate a mouse right-click or middle-click in the virtual 
machine. 
 

Install or Update Parallels Tools 
Parallels Tools are a suite of behind-the-scenes tools that allow seamless operating between 
macOS and Windows or another guest operating system.  

This section gives an overview of Parallels Tools, and has information about how to install them for 
various guest operating systems. 
 

Parallels Tools Overview 

Parallels Tools are a suite of special utilities that help you use your virtual machines in the most 
comfortable and efficient way. With Parallels Tools, you can move the mouse seamlessly between 
the virtual machine and your Mac, change the virtual machine's screen resolution by simply resizing 
its window, synchronize your virtual machine's time and date settings with the time settings of the 
host computer, share your Mac's disks and folders with its virtual machines, copy text and drag 
and drop objects from macOS to a virtual machine and vice versa. 

Parallels Tools are available for the most popular Windows, Linux, and macOS operating systems, 
and include the utilities listed below. All utilities supported by your guest OS are installed in your 
virtual machine as a single package when you install Parallels Tools. 

Utility Available for Description 

Mouse Synchronization Tool 

Windows 

Linux 

macOS 

Mouse Synchronization Tool captures the mouse input 
in the virtual machine each time the pointer moves over 
its window and automatically releases the input when 
the pointer moves outside the window. 

Time Synchronization Tool 

Windows 

Linux  

macOS 

Time Synchronization Tool enables you to customize 
your virtual machine time settings. You can: 

• Automatically synchronize the time settings of 
your virtual machine with your Mac time 
settings. 

• Set up and maintain the time difference 
between your Mac and your virtual machine. 

Drag-and-Drop Tool  Windows 
Drag-and-Drop Tool allows dragging and dropping  files 
between your virtual machines and macOS.  



119 
 

Advanced Topics 
 

Clipboard Synchronization 
Tool 

Windows 

Linux 

Clipboard Synchronization Tool enables you to easily 
exchange texts between: 

• the virtual machine and your Mac. 

• different virtual machines irrespective of the 
guest operating systems installed in them. 

To copy and paste text, you should use the standard  
procedure for the current operating system. For 
example, to copy some text in the Windows guest OS, 
select the text, and press Ctrl+C. To paste this text in 
macOS, press Cmd+V, or select Paste from the 
shortcut menu. 

Dynamic Resolution Tool 

Windows 

Linux 

macOS 

Dynamic Resolution Tool enables you to work with 
dynamic resolution. When you resize the guest OS 
window by dragging its lower right corner, the guest OS 
window resolution changes automatically. 

Shared Folders Tool 

Windows 

Linux 

macOS 

Shared Folders Tool enables you to share Mac folders 
with the virtual machine. 

Shared Profile Tool Windows 

Shared Profile Tool enables you to share your Mac 
desktop, pictures, documents, downloads, music and 
videos with your virtual machine, which allows you to 
access them right from Windows. 

SmartMount 

Windows 

Linux 

macOS 

SmartMount automatically detects volumes connected 
to your Mac and makes them available to the virtual 
machine as well. 

Printing Tool Windows Printing Tool allows you to synchronize the host and 
guest OS printers. 

Tray Integration Tool Windows Tray Integration Tool allows you to use Windows tray 
icons in the Mac menu bar. 

Parallels Tools are located on disc images that are installed together with Parallels Desktop. There 
is a separate Parallels Tools disc image for each type of the supported guest operating systems. 

• prl-tools-win.iso - disc image with Parallels Tools for Windows guest operating systems. 

• prl-tools-lin.iso - disc image with Parallels Tools for Linux guest operating systems. 

• prl-tools-mac.iso - disc image with Parallels Tools for macOS guest operating systems. 

These disc images can be found in the following location on your Mac: 
<username>/Applications/Parallels Desktop/Contents/Resources/Tools. 
 

Parallels Tools for Windows 

Important: To take advantage of much of the functionality Parallels Desktop offers, Parallels Tools must 
be installed. 
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Parallels Tools can be installed in the following Windows guest operating systems: 

• Windows 10 

• Windows 8 

• Windows 7 

• Windows Server 2008 

• Windows Vista 

• Windows XP 

• Windows Server 2003 

• Windows 2000 

Installing Parallels Tools 

If you chose Express Installation when you first installed Windows, Parallels Tools were installed 
automatically after the installation. 

If you didn't choose Express Installation, do the following to install Parallels Tools: 

1 Start Windows (p. 15). 

2 When Windows boots up, choose Install Parallels Tools from the Virtual Machine menu. 

Note: After you choose Install Parallels Tools in Windows 7 and Windows Vista, User Access Control 
(UAC) may ask you whether to allow or deny the Parallels Tools installation. In this case, you need to 
allow the installation. 

3 Click Continue to connect the ISO image with Parallels Tools for Windows to the virtual 
machine's CD/DVD-ROM drive. 

4 Click Install Parallels Tools to start the installation. 

Note: After you click Install Parallels Tools in Windows 7 and Windows Vista, User Access Control 
(UAC) may ask you whether to allow or deny the Parallels Tools installation. In this case, you need to 
allow the installation. 

5 When the installation is complete, click Restart to restart the virtual machine or wait for about 2 
minutes and it will be restarted automatically. 

If the Parallels Tools ISO image doesn't autoplay after you click Continue, the CD/DVD autorun 
must be disabled in your virtual machine. In this case, do the following to install Parallels Tools: 

1 Open My Computer, right-click the Parallels Tools disc and choose Open. 

2 Double-click the PTAgent file to start the installation. 

3 When the installation is complete, click Restart to restart the virtual machine or wait for about 2 
minutes and it will be restarted automatically. 
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To edit the settings of Parallels Tools installed in your virtual machine, use the Options tab in the 
Virtual Machine Configuration dialog. 

Reinstall or Update Parallels Tools 

To reinstall Parallels Tools: 

1 Start Windows (p. 15). 

2 When Windows boots up, choose Reinstall Parallels Tools from the Actions menu. 

This option is available only if Parallels Tools are up-to-date. If Parallels Tools are outdated, you 
will see the Update Parallels Tools option instead. 

Check Whether Parallels Tools Have Been Installed 

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at 
the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and keyboard" appears 
in the status bar of the virtual machine's window, this means that Parallels Tools were not installed. 
When Parallels Tools are installed, you do not need to press any key to release the mouse and 
keyboard - they are released automatically. 
 

Parallels Tools for Linux 

Parallels Tools can be installed in Linux guest operating systems that comply with the following 
requirements: 

• glibc 2.3.4 and later 

• libstdc++ 3.4.6 and later (libstdc++.so.6) 

• gcc 3.4.6 and later (including C++ support) 

• make 3.80 

• X Window System X11R6.7, X11R6.8, X11R6.8.99, X11R7.0, X11R7.1, X11R7.2 (1.3), 
X11R7.3 (1.4) 

• kernel sources or development package 

Note: Some of Parallels Tools, like Shared Folders Tool and Time Synchronization Tool, may also work in 
the Linux operating systems that do not comply with the requirements listed above. 

Preparing for installation 

Before installing Parallels Tools in a Linux virtual machine, perform the following actions: 

• Close all applications running on the virtual machine. 

• If you use a 3D accelerated window manager, disable it. 
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• Make sure that you have the gcc package and kernel sources installed. If these packages are 
not installed, the Parallels Tools installer will inform you about this. The kernel sources package 
name depends on the type of Linux operating system you use: it can be kernel-devel, or 
kernel-headers, or something else. For more information about the kernel sources, refer to 
Installing the GCC package and Kernel Sources in Linux. 

Note: To install Parallels Tools in your virtual machine, you must have the root privileges.  

Installing Parallels Tools in the most recent versions of Linux systems 

If you have one of the most recent versions of Linux OSs (Ubuntu, Fedora) in your virtual machine, 
the prl-tools-lin.iso image file will be mounted automatically after you connect it to the 
CD/DVD drive. To install Parallels Tools, do the following: 

1 Start the virtual machine. 

2 When the operating system boots up, click Actions and choose Install Parallels Tools. 

Note: If the Install Parallels Tools option is grayed out, make sure that your operating system 
complies with the requirements listed above. 

The prl-tools-lin.iso image file will be mounted to the virtual machine's CD/DVD drive. 

You can connect and mount the Parallels Tools ISO image file manually. In the Mac menu bar, 
click Devices > CD/DVD > Connect Image. In the Finder window, go to the hard disk folder 
(normally named "Macintosh HD"), select the /Library/Parallels/Tools/ folder, select 
the prl-tools-lin.iso file, and click Open to connect it to the virtual machine. 

3 Start a terminal in your Linux guest OS. Type the following command to gain the root 
privileges: 

su 

4 Change the directory to the CD/DVD drive directory using 
cd /media/cdrom/ 

Note: In some of the Linux operating systems, the mount point for the virtual CD/DVD drive may appear 
as /media/Parallels\ Tools/. 

5 In the CD/DVD drive directory, enter the following command to launch Parallels Tools 
installation: 

./install 

6 Follow the Parallels Tools Installer instructions to complete the installation. 

7 When the installation of Parallels Tools is complete, restart your virtual machine. 

Installing Parallels Tools in other versions of Linux guest OSs 

To install Parallels Tools in the older versions of Linux OSs, you have to mount the prl-tools-
lin.iso image file manually. Do the following: 

1 Start the virtual machine. 
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2 When the guest OS boots up, choose Install Parallels Tools from the Actions menu. 

Note: If the Install Parallels Tools option is grayed out, make sure that your operating system 
complies with the requirements for Parallels Tools installation. 

The prl-tools-lin.iso image file will be connected to the virtual machine's CD/DVD drive. 

3 Start a terminal in your Linux guest OS. Type the following command to gain the root 
privileges: 

su 

4 Check if the Parallels Tools CD image is mounted by entering 
mount | grep iso9660 

If this command does not return anything, proceed to the next step. 

If this command returns anything like 
/dev/cdrom on /media/cdrom type iso9660 (ro,exec,nosuid,nodev,uid=0), 

skip the next step and proceed to the following one. 

If this command returns anything like 
/dev/cdrom on /media/cdrom type iso9660 (ro,noexec,nosuid,nodev,uid=0) 

with the noexec option present in parentheses, you need to unmount the disc using the 
following command and then proceed to the next step: 

umount /dev/cdrom 

5 To mount the Parallels Tools installation disc image, enter the following: 
mount -o exec /dev/cdrom /media/cdrom 

Note: /dev/cdrom is the virtual machine's CD/DVD drive and /media/cdrom is the mount point for 
this device. In some of the Linux operating systems the virtual CD/DVD drive may appear as /dev/hdb 
and the mount point /mnt/cdrom. Some Linux OSs do not have the CD/DVD drive mount point. In this 
case, you should create the mount point directory manually. 

6 When the installation disc image is mounted, change the directory to the CD/DVD drive 
directory using 

cd /media/cdrom/ 

7 In the CD/DVD drive directory, enter the following to launch Parallels Tools installation: 
./install 

Note: You must have the root privileges to run this command. 

8 Follow the Parallels Tools Installer instructions to complete the installation. 

9 When the installation of Parallels Tools is complete, restart your virtual machine. 

Note: If X Server fails to start in your virtual machine, you can install Parallels Tools manually in text 
mode. 

To edit the settings of Parallels Tools installed in your virtual machine, use the Options tab in the 
Virtual Machine Configuration dialog. 
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How to check if Parallels Tools have been installed 

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at 
the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and 
keyboard" appears in the status bar of the virtual machine's window, this means that Parallels 
Tools were not installed. When Parallels Tools are installed, you do not need to press any key to 
release the mouse and keyboard - they are released automatically. 

Troubleshooting 

Parallels Tools installer can be blocked by SELinux. To solve this problem: 

1 Start a terminal and determine your version of kernel by entering 
uname -r 
2.6.18-8.el5 

2.6.18-8.el5 is the version of your kernel. 

2 Open the /boot/grub/grub.conf file or /boot/grub/menu.lst (depends on the 
version of your Linux operating system) and find the entry that corresponds to your version of 
kernel. 

title Red Hat Enterprise Linux Server (2.6.18-8.el5) 
 root (hd0,0) 
 kernel /vmlinuz-2.6.18-8.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet 
 initrd /initrd-2.6.18-8.el5.img 

3 Type the following text at the end of the entry: 
selinux=0 

and the whole entry will be: 
kernel /vmlinuz-2.6.18-8.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet selinux=0 

4 Save the file and restart the virtual machine. 

After the restart, mount the Parallels Tools disc image and try to install Parallels Tools. 

Update Parallels Tools 

If a newer version of Parallels Tools for Linux is available, the Parallels Tools Installation Agent 
window appears. You're prompted to choose the command to gain root privileges and enter the 
password (if su - root password, if sudo - your user's password). After that, Parallels Tools update 
automatically. 

Reinstall Parallels Tools 

To reinstall Parallels Tools in Linux, first remove Parallels Tools and then install them once again. 
 



125 
 

Advanced Topics 
 

Installing and Upgrading Parallels Tools in Text Mode in Linux 

After upgrading to Parallels Desktop, the X Server may fail to start in Linux virtual machines. To fix 
the problem, you need to install Parallels Tools in text mode. 

1 Start the virtual machine. 

2 When you see a message that X Server failed to start, switch to another virtual console using 
Ctrl+Option+F1 (Ctrl+Alt+F1) and enter your login details. 

3 Choose Install Parallels Tools from the Actions menu to connect the Parallels Tools ISO 
image to your virtual machine. 

Note: If the Install Parallels Tools option is grayed out, make sure that Parallels Tools can be installed 
in your guest operating system. To see the list of guest OSs supported by Parallels Tools, refer to the 
Parallels Tools Overview section in Parallels Desktop User's Guide. 

The prl-tools-lin.iso image file will be connected to the virtual machine's CD/DVD drive. 

4 In the virtual machine console, type the following command to gain the root privileges: 
su 

5 Check if the Parallels Tools CD image is mounted by entering 
mount | grep iso9660 

If this command does not return anything, proceed to the next step. 

If this command returns anything like 
/dev/cdrom on /media/cdrom type iso9660 (ro,exec,nosuid,nodev,uid=0), 

skip the next step and proceed to the following one. 

If this command returns anything like 
/dev/cdrom on /media/cdrom type iso9660 (ro,noexec,nosuid,nodev,uid=0) 

with the noexec option present in parentheses, you need to unmount the disc using the 
following command and then proceed to the next step: 

umount /dev/cdrom 

6 To mount the Parallels Tools installation disc image, enter the following: 
mount -o exec /dev/cdrom /media/cdrom 

Note: /dev/cdrom is the virtual machine's CD/DVD drive and /media/cdrom is the mount point for 
this device. In some of the Linux operating systems the virtual CD/DVD drive may appear as /dev/hdb 
and the mount point /mnt/cdrom. Some Linux OSs do not have the CD/DVD drive mount point. In this 
case, you should create the mount point directory manually. 

7 When the installation disc image is mounted, change the directory to the CD/DVD drive 
directory using 

cd /media/cdrom/ 

8 In the CD/DVD drive directory, enter the following to launch Parallels Tools installation: 
./install 

Note: You must have the root privileges to run this command. 

9 Follow the Parallels Tools Installer instructions to complete the installation. 
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10 When the installation of Parallels Tools is complete, restart your virtual machine. 

For general information on installing Parallels Tools in Linux, refer to Installing Parallels Tools in a 
Linux Guest OS. 
 

Parallels Tools for Mac 

Install Parallels Tools 

To install Parallels Tools in an macOS virtual machine: 

1 Start the macOS virtual machine. 

2 When macOS boots up, choose Actions > Install Parallels Tools and follow the onscreen 
instructions. 

Reinstall Parallels Tools 

To reinstall Parallels Tools: 

1 Start your macOS virtual machine (p. 15). 

2 When Windows boots up, choose Reinstall Parallels Tools from the Virtual Machine menu. 

Update Parallels Tools 

If a newer version of Parallels Tools for Mac is available, Parallels Tools update automatically. 

Check Whether Parallels Tools Have Been Installed 

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at 
the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and keyboard" appears 
in the status bar of the virtual machine's window, this means that Parallels Tools were not installed. 
When Parallels Tools are installed, you do not need to press any key to release the mouse and 
keyboard. They are released automatically. 
 

Picture in Picture Mode 
When you switch to Modality, you can resize the virtual machine windows and place them side by 
side with your Mac's applications. 

In the Modality mode, you can: 

• Resize the Windows window while keeping its shape by dragging its lower-right corner. 

• Resize the Windows window by pressing and holding the Option (Alt) key and dragging the 
lower-right corner of the window. 
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• Resize the Windows window and dynamically adjust the screen resolution by pressing and 
holding the Shift and dragging the lower-right corner of the window. 

Using the Picture in Picture settings, you can configure the virtual machine appearance and 
behavior when it is running in the Picture in Picture mode. In the Picture in Picture mode, you can 
resize the virtual machine windows and place them side by side with your Mac applications. A 
Picture in Picture window can be scaled to any size, and its content will still be active. This allows 
you to monitor the tasks running inside the virtual machine while you are working on the Mac side. 

To edit these settings, do the following: 

1 Click the Parallels icon  in the menu bar and choose Configure. Or сlick Actions in the 
Parallels Desktop menu bar at the top of the screen and choose Configure. 

2 In the Virtual Machine Configuration window, click Options and select the settings name in 
the sidebar. 

You can configure the settings in this pane even when the virtual machine is running. 
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In the Picture in Picture mode, the virtual machine window becomes transparent by default. You 
can specify the level of visibility in the Opacity field by dragging the slider between Transparent 
and Opaque. You can change the level of transparency for your virtual machine that is running 
when it is in the Picture in Picture mode. 

To manage the behavior of the virtual machine window in the Picture in Picture mode, use the 
following options selected by default: 

• Keep on top of other windows. Clear this option if you do not want the virtual machine 
window to appear on top of all other open windows when the virtual machine is in Picture in 
Picture mode. 

• Show window on all Spaces. Clear this option if you don't want the virtual machine window to 
be displayed on all Spaces. 

• Activate window by Dock icon only. Select this option if you want to make the virtual 
machine window inactive. When selected, you will click "through" the window. If you need to 
make the window active again and capture the mouse or keyboard input, click the virtual 
machine icon in the Dock. 

 

Hide and Show Parallels Desktop 
When Parallels Desktop is running, you can hide and show it and all its windows by holding down 
the Function (Fn) key and pressing the F6 key. 

If Parallels Desktop is visible but running in the background, pressing Fn-F6 brings Parallels 
Desktop and all its windows to focus. 

Note: Most function keys (F1, F2, and so on) on Mac keyboards serve as specific control keys, such as 
volume and brightness controls, and you must hold down the Fn key as you press the function key to 
trigger an alternate, application-specific function. If you want to set function keys to be used for alternate 
functions without having to press the Fn key, choose Apple menu > System Preferences and click 
Keyboard. Then click the Keyboard tab and choose Use all F1, F2, etc. keys as standard function 
keys. 

 

Remove Parallels Desktop 
To remove Parallels Desktop, open your Applications folder and drag the Parallels Desktop 
application to the Trash. 
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Adding and Removing Devices 
Adding new devices to a virtual machine is easier than connecting new devices to a real computer. 
Removing or disconnecting devices is also easy. The following virtual devices can be added to the 
configuration or removed from it: 

• virtual hard disk drive 

• CD/DVD drive 

• floppy disk drive 

• network adapter 

• printer port 

• sound device 

• USB controller 

• serial port 

Any of the aforementioned devices can be added to the corresponding virtual machine only when it 
is stopped. 

Note: To be able to connect any virtual device to a real one, you should have system privileges to access 
the real device. Otherwise, the real device will not appear in the list of available devices even though it is 
installed on your computer. 

Adding a New Device to a Virtual Machine 

1 Choose Configure from the Actions menu to open Virtual Machine Configuration. 

2 Click the Hardware button at the top of the Virtual Machine Configuration dialog to open the 
pane for editing hardware devices. 

3 Click the Add button  in the bottom part of the Virtual Machine Configuration dialog and 
select the device to be added to your virtual machine. 

Note: The Add button is disabled when the virtual machine is running. You need to stop the virtual 
machine before you can use this button. 
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4 If you selected any device except for a hard disk, the corresponding device with a typical 
configuration is added at once and ready for use. 

If you selected a hard disk, you should specify some parameters: 

• The hard disk type: a new image file or an existing one. 

• The hard disk location. Provide the path on your Mac to the existing image file or the path 
and name for the new image file. By default, Parallels Desktop offers to save the new image 
file in the virtual machine PVM bundle. 

• The hard disk size for the new hard disk image file. 

• For the new hard disk image file, you can choose one of the following formats: Expanding or 
Plain. By default, the hard disk will have the Expanding format. To create a Plain hard disk, 
clear the Expanding disk option. If you want the virtual hard disk to be split, select the Split 
the disk image to 2 GB files option. For more information on hard disk formats, refer to 
Support for Virtual and Real Disks (p. 131). 

 

Click OK, to add the hard disk. After you added a new virtual hard disk to the virtual machine 
configuration, it will be invisible to the operating system installed inside the virtual machine until 
the moment you initialize it. For detailed information on how to initialize the newly added hard 
disk, see Initializing the Newly Added Disk (p. 132). 

After the new device is added, you can manage its properties as usual and start using it. 

Removing Devices From the Virtual Machine Configuration 

1 Choose Configure from the Actions menu to open Virtual Machine Configuration. 

2 Click the Hardware button at the top of the Virtual Machine Configuration dialog to open the 
pane for editing hardware devices. 

3 Select the device you want to remove and click the Remove button  in the bottom part of 
the Virtual Machine Configuration dialog. 
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Support for Virtual and Real Disks 

This section lists the types of disks that can be used by Parallels virtual machines and provides the 
information about basic operations you can perform on these disks. 

Supported Types of Hard Disks 

Parallels virtual machines use virtual hard disks as their hard disks. 

Virtual Hard Disks 

The capacity of a virtual hard disk can be set from 100 MB to 2 TB. 

Virtual hard disks can be of either plain or expanding format. 

plain A plain virtual hard disk image file has a fixed size.  The size is determined when the 
disk is created. 

expanding An expanding virtual hard disk image file is small initially. Its size grows as you add 
applications and data to the virtual hard disk in the guest OS. 

When you create a virtual machine, the disk is created in the expanding format. You can change 
the disk format in the Hard Disk pane of the Virtual Machine Configuration dialog. To add a plain 
hard disk to your virtual machine, clear the Expanding disk option when adding a hard disk to the 
virtual machine. 

Split disks 

A virtual disk of either format can be a single-piece disk or a split disk. A split disk is cut into 2 GB 
pieces and is stored as a single .hdd file. 

CD/DVD Discs and Their Images 

Parallels Desktop can access real CD/DVD discs and images of CD/DVD discs. 

Parallels Desktop has no limitations on using multi-session CD/DVD discs. A virtual machine can 
play back audio CDs without any limitations on copy-protected discs. 

If your host computer has a recordable optical drive, you can use it to burn CD or DVD discs in a 
virtual machine. 

Parallels Desktop supports CD/DVD disc images in the ISO format. 

Note: DMG disk images made with macOS Disk Utility are also supported by Parallels Desktop. When 
creating such an image, make sure you create a read-only and uncompressed image without any 
encryption. 
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Floppy Disks and Floppy Disk Images 

Parallels Desktop can use two types of floppy disks: 

• Real diskettes inserted into a real floppy disk drive that is connected to the virtual machine. 

• Floppy disk image files having the .fdd extension and connected to the virtual machine. 

Parallels Desktop treats floppy disk images like real diskettes. Parallels Desktop supports floppy 
disk image files that have the .fdd extension and 1.44 MB size. 
 

Initialize a Newly Added Disk 

After you added a new blank virtual hard disk to the virtual machine configuration, it will be invisible 
to the operating system installed inside the virtual machine until the moment you initialize it. To learn 
how to initialize the newly added hard disk, please refer to the help resources of the operating 
system installed in the virtual machine. 
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Install Parallels Tools for Seamless Operation 
Between Windows and macOS 
Many issues with using Parallels Desktop can be solved by installing Parallels Tools. 

Parallels Tools help you work with Windows in the most comfortable and efficient way. With 
Parallels Tools, you can: 

• Move the mouse seamlessly between Windows and macOS 

• Synchronize the Windows time and date settings with those of macOS 

• Share your macOS disks and folders with Windows 

• Copy text and drag and drop objects from macOS to Windows 

Important: Once you install Parallels Tools and restart Windows, you don't have to do anything else. 
Parallels Tools automatically just work, without any action or configuration on your part. 

To install Parallels Tools: 
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1 Start Windows (p. 15). 

2 Choose Actions > Install Parallels Tools and follow the onscreen instructions. 

For more information on installing and updating Parallels Tools, see Parallels Tools for Windows (p. 
119). 
 

Find Settings 
If you want to change a setting in Parallels Desktop but you aren't sure where to find the setting, 
you can search for it by doing the following: 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Configure. 

• Click Actions in the Parallels Desktop menu bar at the top of the screen and choose 
Configure. 

2 Type a word or phrase in the search field. Any settings related to your search are highlighted. 
 

Restore Virtual Machine Default Settings 
When working with a virtual machine, you can change different virtual machine settings, such as an 
amount of memory, video memory, number of CPUs, sharing settings, etc. To restore default 
settings: 

1 Do one of the following (the virtual machine must be shut down): 

• In Control Center, right-click the virtual machine you want to configure and click Configure. 

• If the virtual machine window is open, click Actions > Configure. 

2 In the virtual machine configuration dialog, find the pane with the settings that you want to 
restore and click Restore Defaults. 

 

Memory Usage Problems 
The amount of Mac's physical memory required for each virtual machine operation can be 
represented as follows: 

Virtual Machine Memory = Guest OS Memory + Video Memory + Virtual Machine Monitor Memory 

• Guest OS Memory is the amount of RAM available to your guest operating system. You can 
configure the guest OS memory amount in the CPU & Memory pane of the virtual machine 
configuration dialog. 
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• Video Memory is the amount of physical memory available to the virtual machine's video card. 
You can adjust the video memory amount in the Graphics pane of the virtual machine 
configuration dialog. 

• Virtual Machine Monitor is the module responsible for the guest operating system virtualization. 
It consumes memory to perform operations of guest virtual devices and performs virtual paging 
emulation. The amount of memory required for the Virtual Machine Monitor operation depends 
on the guest OS and varies from 50 MB to 200 MB. 

Memory Overcommitment 

If you have several virtual machines running simultaneously and you are trying to start one more 
virtual machine, you may come across the memory over commit. If so, Parallels Desktop informs 
you with the corresponding message. If you start one more virtual machine, this may significantly 
slow down all your virtual machines. To solve this problem, you can: 

• Stop one or several of your running virtual machines; or 

• Edit your virtual machines' configurations so they consume less memory. 
 

Windows Seems Slow 
If Windows performance seems slow, try the following: 

• Quit applications and programs you aren't using: If you run a number of memory-
consuming applications and programs simultaneously, Windows performance may become 
slow. Quit any applications that you aren't using. You can also use Activity Monitor (located in 
the macOS Finder in Applications > Utilities) to see how much of your Mac's memory each 
application is using. That way, you'll have a better idea of which applications cause 
performance to degrade the most. 

• Change how much memory is allocated to Windows: Parallels Desktop is set to allocate a 
certain amount of your Mac's available RAM memory to Windows and the rest to macOS. If too 
much memory is allocated to Windows, macOS may slow down, which in turn can cause 
Windows programs to slow down because they're running on top of macOS. If, on the other 
hand, too much memory is allocated to macOS, then macOS applications may run well but 
Windows programs might slow down.  

To optimize the performance of both Windows and macOS, set the memory allocated to 
Windows (p. 48) to be somewhere within the recommended range, indicated by the graphic 
under the memory slider in the CPU & Memory configuration panel. 

• Antivirus software may slow down your virtual machine: Windows may become slower after 
you install antivirus software. To be protected, you have to sacrifice performance. 

Note: Do not install more than one Windows antivirus program. 

• Run fewer virtual machines at once: If you are running multiple operating systems at once 
using Parallels Desktop, stop one or more of them to improve performance of the others. 
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• Run Windows locally: If you start Windows stored on an external storage device connected to 
your Mac (for example, an external USB disk drive), its performance will be lower than if it were 
stored on your Mac. 

• Tune Windows for speed: To speed up Windows, select Tune Windows for speed in the 
Optimization pane. 

• Disable log messages: If you select Use detailed log messages in the Advanced pane of 
Parallels Desktop Preferences, Parallels Desktop will start creating a more detailed log file. It 
can be helpful for the Parallels support team, but uses more hard disk space and may slightly 
lower the system performance. 

 

Pressing Ctrl+Alt+Del 
As a Windows user, you might know that you can press the Ctrl+Alt+Del key combination to make 
available troubleshooting options, such as starting the Task Manager or changing a password. 

To mimic pressing Ctrl+Alt+Del in Parallels Desktop: 

• Press fn+Ctrl+Option+Del. 
 

My Password Isn't Working 
If Parallels Desktop doesn't accept your password, try the following: 

• Be sure that Caps Lock is not on. If Caps Lock is on, an indicator appears in the password 
field. To turn Caps Lock off, press the Caps Lock key. 

 

• Be sure that the keyboard is set to the correct language. If the keyboard is set to a language 
that doesn't belong to the group of Romance languages, an icon in the password field indicates 
the keyboard language setting. 

 
 

My Virtual Machine Doesn't Boot 
If your virtual machine doesn't boot correctly, most probably it's because there isn't any operating 
system installed. To install an operating system, do the following: 

1 Prepare the OS installation media: 

• If you have an OS installation disk, insert it into the DVD drive of your Mac. 
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• If you have a USB drive with the OS installation files, connect it to your Mac. 

• If you have a disk image, copy it to your Mac. 

2 Restart the virtual machine by doing one of the following: 

• Click Actions > Restart. 

• Click the Parallels icon  in the menu bar and choose Actions > Restart. 

3 And follow the onscreen instructions. 
 

I'm Having Problems Connecting to the Internet 
When you install Windows, it is automatically configured to share your Mac's Internet connection. 
For details on configuring Windows' network and Internet connection, see the section on 
connecting to the Internet or a network (p. 46). 
 

I'm Having Problems with Antivirus Software 
Because of the close integration between Parallels Desktop and macOS, some Parallels Desktop 
processes may be detected as malicious by antivirus software installed on your Mac. 

To prevent the antivirus software from blocking Parallels Desktop processes, perform a full system 
scan using the antivirus software, and then if no viruses are detected, add the Parallels Desktop 
processes to the list of trusted processes. For information on how to do this, refer to your antivirus 
software Help. 

Important: The names of Parallels Desktop processes usually start with prl or parallels. 
 

The F8 Key Isn't Working Correctly 
In macOS, the F8 key and Ctrl+arrow key combination are reserved for triggering Spaces (a feature 
that lets you organize your windows on multiple desktops). Because of this, the F8 key and 
Ctrl+arrow key may not function correctly with Windows programs. 

If you are experiencing this problem, change the Spaces hotkeys settings. See Mac Help for more 
information. From the Finder, choose Help > Mac Help or Help > Help Center and search for 
"Spaces." 
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Checking the Build Number 
To check the version and build number of the Parallels Desktop software you are using, do one of 
the following: 

• Click the Parallels icon  in the menu bar and choose About Parallels Desktop. 

• If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop 
> About Parallels Desktop. 

A window appears showing the build number. 
 

Send Technical Data to Parallels 
To help improve the quality of Parallels Desktop, you can send technical data to Parallels. 

If Windows is forced to shut down because of an error, Parallels Desktop automatically opens a 
Send Technical Data form. If you notice unusual behavior in Parallels Desktop, you can also send 
technical data manually. 

To send technical data: 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Help > Send Technical Data. 

• Click Help in the Parallels Desktop menu bar at the top of the screen and choose Send 
Technical Data. 

2 Describe what you were doing when the problem occurred, and fill out the form. 

Note: You can review the problem report components that will be sent to the Parallels support team 
and deselect some of them in the Technical Data Report Details window, if desired. To open this 
window, click See Details. 

If Parallels Desktop auto-generates a technical data report, the report window contains the 
Send a solution to me when available option. After the report is sent, Parallels engineers start 
investigating the problem. When they find any workaround or get any news about the reported 
issue, you will be notified by email. 

3 Click Send Report. 

Parallels team uses error reports to improve the product quality but doesn't respond to them. 
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Get Support 
If you have any question or problem with Parallels Desktop, you can find an answer or solution in 
the following places: 

• Parallels Desktop knowledgebase articles; 

• Parallels forums; 

• Parallels Desktop documentation; 

• Parallels Facebook and Twitter; 

• contact the Parallels support team (phone, email, chat). 

To get more info about the items mentioned above, visit the Parallels support center: 

1 Do one of the following: 

• Click the Parallels icon  in the menu bar and choose Help > Support Center. 

• Click Help in the Parallels Desktop menu bar at the top of the screen and choose Support 
Center. 

 



 

 

This glossary defines terms and spells out abbreviations used in Parallels Desktop documentation. 
References to terms defined elsewhere in the glossary appear in italics. 

Administrator. A user with administrative privileges. 

Active volume: The volume of the physical source computer that is used as a boot volume for the 
active operating system.  

Bootable hard disk. A disk used by the operating system to boot from, usually a disk that has an 
operating system installed. 

Boot Volume. A hard disk partition from which the operating system boots. 

Configuration file. A file specifies the virtual machine's hardware configuration, the devices it uses, 
and other settings. It is created automatically when you create a new virtual machine. See also PVS 
file. 

CPU. Stands for central processing unit. It is an internal part of the computer. See also Processor. 

Disks in the new format. Disks of virtual machines that were created or used in Parallels hardware 
virtualization products starting from version 3.0. 

Expanding format. A virtual hard disk format. An expanding virtual hard disk image file resides on 
your host computer and is small initially. Its size grows as you add applications and data to the 
virtual machine. 

FireWire connection. A wired connection that enables a high-speed data transmission between 
computers. 

Guest operating system (guest OS). An operating system installed inside your virtual machine. 

Host computer: The computer that is used to run virtual machines. In case of Parallels Desktop for 
Mac, it is your Mac. 

Hot key. A user-defined key or combination of keys that provides quick access to applications and 
commands. See also Shortcut. 

HDD file. During the creation, the virtual machine acquires a virtual hard disk file with the .hdd 
extension. See also virtual hard disk file. 
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Host-only networking. Virtual machine network connection mode that creates a private network 
between the host computer and its virtual machines, which makes the virtual machines available 
from the host computer only. 

ISO image. A special file that contains the entire contents of a CD or DVD disc commonly used to 
install an operating system. 

Image file. A single file containing the complete contents and structure of a data storage medium 
or device, such as a hard disk drive, CD, or DVD. 

IP address. A unique address that is assigned to a physical computer or a virtual machine that 
participates in computer networking. 

Linux computer. A physical computer that has a Linux operating system installed. 

Merged disk. A split disk whose parts were merged into a single disk. 

Modality. One of the view modes you can use to work with Windows. In Modality mode, the 
Windows desktop appears in a window and scales in size as you resize the window. Also, you can 
set this window to always stay on top of other windows, and you can adjust its transparency level 
so you can see through it when you're working with other applications. 

OS. Operating system. 

Parallels Desktop for Mac. An application that enables you to create, manage, and use virtual 
machines on your Mac. 

Parallels Tools. A set of Parallels utilities that ensures a high level of integration between the 
primary and the guest operating systems. 

Plain format. A virtual hard disk format. A plain virtual hard disk image file resides on the host 
computer and has a fixed size that cannot be changed. 

Preboot Execution Environment (PXE). An environment to boot computers using a network 
interface independently of available data storage devices (like hard disks) or installed operating 
systems. 

Primary operating system (primary OS). Operating system that controls the I/O devices of the 
computer and that is loaded when the physical computer is turned on. It is the operating system of 
the physical computer where the Parallels Desktop application is installed. 

Processor. The central processing unit, or CPU. It is an internal part of the computer. 

PVS file. A virtual machine configuration file that contains information about the virtual machine 
resources, devices and other settings. 

Shared networking. Virtual machine network connection mode that allows the virtual machine to 
use the host computer network connections. In this mode, the virtual machine is invisible to other 
computers on the network the host computer belongs to. 
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Shortcut. A user-defined key or combination of keys that provides quick access to applications 
and commands. See also Hot key. 

Snapshot. A copy of the virtual machine state at a particular point of time. The files related to 
snapshots are stored in a special subfolder in the virtual machine's folder. 

Split disk. A split disk is cut into 2 GB pieces, but is stored as a single HDD file. Split disks allow 
you to transfer the data stored on a split disk piece by piece using a USB drive or other media that 
have limited space and cannot store a large virtual hard disk image file. 

Terminal. In macOS and GNU/Linux operating systems, a utility that enables you to access the 
command line. 

Third-party virtual machine. A virtual machine created in a third-party virtualization product. 

Virtual hard disk (virtual disk). A file that emulates the virtual machine's hard disk. 

Virtual Machine. The computer emulated using Parallels Desktop. A virtual machine has its own 
virtual hardware and requires an operating system to control its hardware. The installed operating 
system and its applications are isolated inside the virtual machine and share physical hardware 
resources of the host computer. 

Virtual Machine Configuration. Like any physical computer, a virtual machine has its own 
configuration which is set during the creation and can be later modified. The virtual machine 
configuration settings are stored in a PVS file. 

Virtual machine files. Files stored in a virtual machine folder. A virtual machine has at least two 
files: configuration file and virtual hard disk file. 

Virtual hard disk file. During the creation, the virtual machine acquires a virtual hard disk file with 
the .hdd extension. This file performs the functions of a real hard disk. See also HDD file. 

Virtual machine template. A virtual machine that can be cloned to multiple virtual machines that 
will have the same configuration and data that the virtual machine template had. 

VM. See Virtual Machine. 

Windows computer. A physical computer that has a Windows operating system installed. 
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